Bug 55358 - Installer hangs when loading aic7xxx driver on my L440GX+
Installer hangs when loading aic7xxx driver on my L440GX+
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-10-30 04:23 EST by Meder Bakirov
Modified: 2007-04-18 12:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-11-01 02:04:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
The output of the dmidecode program when run on the server that fails to install with RedHat 7.2 (15.10 KB, text/plain)
2001-10-31 07:23 EST, Michael Sinz
no flags Details

  None (edit)
Description Meder Bakirov 2001-10-30 04:23:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
Installer stops on the stage, loading aic7xxx driver on my L440GX+ 
chipset-based server.
But when I switch console to ALt+F4 I see messages due to timeout on my 
SCSI adapter... And it loops...
Comment 1 Michael Sinz 2001-10-30 11:56:36 EST
I have run into this same problem on an Intel dual processor (550MHZ PIII)
motherboard (440GX+ which includes SCSI)

This same problem existed in the 7.1 Redhat and required a special install boot
floppy to work around (See the RedHat 7.1 install gotchas page at
http://www.redhat.com/support/resources/gotchas/7.1/gotchas-71.html for more

I am somewhat surprised that the new 7.2 release has problems on this same
Comment 2 Bill Nottingham 2001-10-30 22:39:23 EST
Assigning to kernel so the relevant explanation can be posted.
Comment 3 Arjan van de Ven 2001-10-31 04:24:04 EST
Unfortionatly the 440GX problem is a bios bug, and due to "Intel Proprietary
Information" we cannot work around it properly. The on thing you can try, and
that works most of the time, is passing "apic" on the syslinux prompt as kernel

The official text Intel and Red Hat agreed on is:
Most implementations using the 440GX chipset require the "apic"
option to function correctly.  When this is the case, providing
DMI information to Red Hat as documented below[1] may allow us to
automate that setting in the future.

On some systems, the "apic" boot flag may not work.  Unfortunately,
because of Intel Proprietary information, these platforms are not
supported at this time.

[1] wget http://people.redhat.com/arjanv/dmidecode.c
    gcc dmidecode.c -o dmidecode
    ./dmidecode | \
       mail -s 'requires apic option to install' hardwarebugs-list@redhat.com
Comment 4 Michael Sinz 2001-10-31 07:23:33 EST
Created attachment 35821 [details]
The output of the dmidecode program when run on the server that fails to install with RedHat 7.2
Comment 5 Arjan van de Ven 2001-10-31 07:29:25 EST
Just to confirm: "apic" makes it work ?
Comment 6 Meder Bakirov 2001-11-01 02:04:23 EST
Hi there!

I have tried "linux apic" at boot promt and it worked for me!

Comment 7 Meder Bakirov 2001-11-01 05:14:47 EST
I have just installed Redhat 7.2 on my L440GX+ box - everything went smooth!
At boot promt I gave "expert apic"

That's all!

Comment 8 Benjamin Scott 2003-05-06 22:14:11 EDT
See also Bug 78234 (against RHL 8.0), which describes a fix for when the
APIC/SMP workaround does not work.  (In short: Fixed in pristine kernel

Note You need to log in before you can comment on or make changes to this bug.