Bug 55363 - Kernel internal clock of IA-64 Linux become being late.
Kernel internal clock of IA-64 Linux become being late.
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
ia64 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-30 07:01 EST by Shinya Narahara
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-09 08:47:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shinya Narahara 2001-10-30 07:01:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [ja] (WinNT; U)

Description of problem:
By running for a long time, the difference of the time according to "hwclock" and "date" gets
larger and larger.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. boot IA-64 Linux (RH7.1, kernel is 2.4.3-12smp)
2. Don't touch it for a long time. ex. 1 week or so.
3. hwclock ; date
	

Actual Results:  The result of "hwclock" is similar to the one of "date".

Expected Results:  The difference might be 10 minutes or more large.
After 1 month heat run, we are surprise the difference was about 1 hour !


Additional info:

This may be caused by the interval of kernel internal clock.
To avoid this,
  1. fix kernel to have suitable interval of kernel clock.
  2. fix /etc/crontab to adjust kernel clock by using "hwclock" command.
  3. Use ntpd

Actually this bug is very serious because IA-64 Linux is using on enterprise and huge
mathematical calculation. This significantly affects the performance test and any
test programs.
Comment 1 Arjan van de Ven 2001-10-30 08:58:16 EST
Is this with the e100 or the qla2x00 driver loaded ?
Comment 2 Shinya Narahara 2001-10-30 20:16:13 EST
Yes tye machine has e100.
We have 2 systems, Intel Lion(2way) and HITACHI ColdFusion-1(8way),
both system have e100(Ver1.6.6) and DAC960(Ver 2.4.10).
And also Lion has qla1280, CF-1 has aic7xxx_mod.

However I wonder if these devices have a relation with kernel clock...
Comment 3 Bill Nottingham 2001-10-30 22:41:46 EST
I've noticed ia64 machines losing time even without e100/qla2x00.
Comment 4 Shinya Narahara 2001-11-06 03:50:26 EST
We confirmed that the kernel 2.4.9-6smp from redhat ftp site had this issue yet.
The kernel internal clock had a difference 0.5msec a sec, then the difference
between internal and hardware clock may be 30 or 40 sec a day.
Comment 5 Arjan van de Ven 2001-11-06 04:19:54 EST
e100 has a relation to the kernel clock in that it disables interrupts for 500
miliseconds sometimes, and that makes the kernel miss timer interrupts....
Comment 6 Shinya Narahara 2001-11-06 21:56:43 EST
We tested the system with eepro100 instead of e100, however we have this issue yet.
I guess this is not a issue related with e100 driver.
Comment 7 Shinya Narahara 2001-11-26 20:15:11 EST
FYI:
This issue may be complex both hardware(firmware) and kernel.
Our hardware team is trying to fix this issue by customizing its firmware...
Comment 8 Arjan van de Ven 2001-11-27 03:48:09 EST
To be honest, I find it perfectly reasonable that if you want exact time, you
use ntpd .... Even normal PC's have a clockdrift, some up to 5 to 10 minutes a day. 
ntpd is there for a reason ;(
Comment 9 Shinya Narahara 2001-11-29 01:50:40 EST
Our hardware team finally makes new firmware(SAL) and success to reduce the
effects of this issue. So, this doesn't have to be fixed, but this should be yet.
However we can avoid this to make new SAL, many IA64 machines are made
by Intel and I wonder that they dicide to make new SAL to solve this.

I agree you, ntp is a best solution against this, but it remains some problems
if I use ia64 machine as stand-alone(without any ntp servers)...

BTW, one of reasons of this issue may be /etc/rc.d/init.d/halt script in
initscripts package, the line below:

  runcmd $"Syncing hardware clock to system time" /sbin/hwclock $CLOCKFLAGS

The hareware clock is getting later and later if we don't have any ntp server
and do shutdown every day, because the hw clock is set by *broken* system clock
at every shutdown time. So I recomend to remove this line, as you know,
the system clock is very inaccurate comparing with hw clock.
Comment 10 Alan Cox 2003-06-09 08:47:31 EDT
7.1 IA64 is no longer supported. Closing. If this is in the supported products
too  please update version and reopen

Note You need to log in before you can comment on or make changes to this bug.