This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 553636 - dsgw and ds has problems in schema
dsgw and ds has problems in schema
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: UI - Gateway/Phonebook (Show other bugs)
1.1.3
i386 Linux
low Severity high
: ---
: ---
Assigned To: Rich Megginson
Viktor Ashirov
: VerifiedUpstream
Depends On:
Blocks: 389_1.2.7
  Show dependency treegraph
 
Reported: 2010-01-08 08:56 EST by Markku Sopula
Modified: 2015-12-07 12:18 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Centos 5.4 i386
Last Closed: 2015-12-07 12:18:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Markku Sopula 2010-01-08 08:56:39 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install from epel
2. setup via setup-ds-admin.pl
3. run setup-ds-dsgw
4. Restart the server
5. Try add new user via dsgw (with admin account)
  
Actual results:
Adding user...
Problem

An error occurred while contacting the LDAP server.
(Object class violation - unknown object class "nsaimpresence" )
The directory server could not honor your request because it violates the schema requirements. Typically, this means that you have not provided a value for a required field. It could also mean that the schema in the directory server needs to be updated.

Expected results:
User added to database

Additional info:
Also graphics in dsgw are not right. worked better with previos versions. Seems that nssaimpresence is removed from schema, but not from dsgw. Older version has nssaimpresence also in ldap schema.
Comment 2 Rich Megginson 2010-10-20 17:13:55 EDT
commit 34a9b5878c33b7ae6c7f888dc2e056f533a887df
Author: Rich Megginson <rmeggins@redhat.com>
Date:   Tue Oct 12 11:06:41 2010 -0600
    the aim schema has been removed from 389 - aim presence is disabled by
    default - disable the aim stuff in dsgw by default - added a new config
    param - have-aim-schema - enable this if you really want to use aim
    schema

Note You need to log in before you can comment on or make changes to this bug.