Bug 553713 - qgis FTBFS
qgis FTBFS
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qgis (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
Depends On:
Blocks: sip-4.10
  Show dependency treegraph
 
Reported: 2010-01-08 13:08 EST by Rex Dieter
Modified: 2010-02-05 18:03 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.0.2-6.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-05 18:03:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2010-01-08 13:08:07 EST
build failure,
http://koji.fedoraproject.org/koji/buildinfo?buildID=149926

...
nstalling: /builddir/build/BUILDROOT/qgis-1.0.2-5.fc13.i386/usr/share/qgis/i18n/qgis_sv.qm
-- Installing: /builddir/build/BUILDROOT/qgis-1.0.2-5.fc13.i386/usr/share/qgis/i18n/qgis_de.qm
-- Installing: /builddir/build/BUILDROOT/qgis-1.0.2-5.fc13.i386/usr/share/qgis/i18n/qt_fr.qm
-- Installing: /builddir/build/BUILDROOT/qgis-1.0.2-5.fc13.i386/usr/share/qgis/i18n/qgis_he.qm
-- Installing: /builddir/build/BUILDROOT/qgis-1.0.2-5.fc13.i386/usr/share/qgis/i18n/qgis_ja.qm
-- Installing: /builddir/build/BUILDROOT/qgis-1.0.2-5.fc13.i386/usr/share/qgis/i18n/qt_pl.qm
-- Installing: /builddir/build/BUILDROOT/qgis-1.0.2-5.fc13.i386/usr/share/qgis/i18n/qgis_ka_GE.qm
-- Installing: /builddir/build/BUILDROOT/qgis-1.0.2-5.fc13.i386/usr/share/qgis/i18n/qt_ja_jp.qm
-- Installing: /builddir/build/BUILDROOT/qgis-1.0.2-5.fc13.i386/usr/share/qgis/i18n/qgis_cs_CZ.qm
-- Installing: /builddir/build/BUILDROOT/qgis-1.0.2-5.fc13.i386/usr/share/qgis/i18n/qt_pt.qm
+ chrpath --delete /builddir/build/BUILDROOT/qgis-1.0.2-5.fc13.i386/usr/bin/qgis '/builddir/build/BUILDROOT/qgis-1.0.2-5.fc13.i386/usr/lib/python2.6/site-packages/qgis/*.so'
open: No such file or directory
elf_open: Invalid argument
error: Bad exit status from /var/tmp/rpm-tmp.35i0kM (%install)
RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.35i0kM (%install)
Child returncode was: 1
EXCEPTION: Command failed. See logs for output.
 # ['bash', '--login', '-c', 'rpmbuild -bb --target i686 --nodeps builddir/build/SPECS/qgis.spec']
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/mock/trace_decorator.py", line 70, in trace
    result = func(*args, **kw)
  File "/usr/lib/python2.4/site-packages/mock/util.py", line 324, in do
    raise mock.exception.Error, ("Command failed. See logs for output.\n # %s" % (command,), child.returncode)
Error: Command failed. See logs for output.
 # ['bash', '--login', '-c', 'rpmbuild -bb --target i686 --nodeps builddir/build/SPECS/qgis.spec']
LEAVE do --> EXCEPTION RAISED
Comment 1 Kevin Kofler 2010-02-05 15:31:58 EST
This is due to trying to use string comparisons for version numbers:
-- SIP is required in version 4.7 or later!
-- Python bindings disabled due dependency problems!

I'm on it.
Comment 2 Kevin Kofler 2010-02-05 16:21:33 EST
Actually, this is the offending code:
      # check for SIP version
      # minimal version is 4.7 (to support universal builds)
      SET (SIP_MIN_VERSION 040700)
      TRY_RUN_PYTHON (RES "import sip\nprint '%x' % sip.SIP_VERSION" SIP_VERSION)
      IF (SIP_VERSION EQUAL "${SIP_MIN_VERSION}" OR SIP_VERSION GREATER "${SIP_MIN_VERSION}")
        SET (SIP_IS_GOOD TRUE)
      ENDIF (SIP_VERSION EQUAL "${SIP_MIN_VERSION}" OR SIP_VERSION GREATER "${SIP_MIN_VERSION}")
    
      IF (NOT SIP_IS_GOOD)
        MESSAGE (STATUS "SIP is required in version 4.7 or later!")
      ENDIF (NOT SIP_IS_GOOD)


The problem is that this is now 40a00 and so checking it with an integer comparison for decimal numbers fails.
Comment 3 Kevin Kofler 2010-02-05 18:03:00 EST
qgis-1.0.2-6.fc13 built successfully.

Note You need to log in before you can comment on or make changes to this bug.