Bug 553715 - qzion FTBFS
qzion FTBFS
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qzion (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: john5342
Fedora Extras Quality Assurance
:
Depends On:
Blocks: sip-4.10
  Show dependency treegraph
 
Reported: 2010-01-08 13:12 EST by Rex Dieter
Modified: 2010-01-09 09:51 EST (History)
2 users (show)

See Also:
Fixed In Version: qzion-0.4.0-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-09 09:51:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2010-01-08 13:12:38 EST
build failure,
http://koji.fedoraproject.org/koji/taskinfo?taskID=1908341

...
BUILDROOT/qzion-0.4.0-6.fc13.x86_64/usr/include/qziontextblock.h
-- Installing: /builddir/build/BUILDROOT/qzion-0.4.0-6.fc13.x86_64/usr/include/qzionrectangle.h
-- Installing: /builddir/build/BUILDROOT/qzion-0.4.0-6.fc13.x86_64/usr/include/qziongroup.h
-- Installing: /builddir/build/BUILDROOT/qzion-0.4.0-6.fc13.x86_64/usr/include/qzionclippedgroup.h
-- Installing: /builddir/build/BUILDROOT/qzion-0.4.0-6.fc13.x86_64/usr/include/qzionimage.h
-- Installing: /builddir/build/BUILDROOT/qzion-0.4.0-6.fc13.x86_64/usr/include/qzioncanvas.h
-- Installing: /builddir/build/BUILDROOT/qzion-0.4.0-6.fc13.x86_64/usr/include/qzionobject.h
-- Installing: /builddir/build/BUILDROOT/qzion-0.4.0-6.fc13.x86_64/usr/include/qzionabstractcanvas.h
-- Installing: /builddir/build/BUILDROOT/qzion-0.4.0-6.fc13.x86_64/usr/include/qzioncustomobject.h
CMake Error at src/cmake_install.cmake:53 (FILE):
  file INSTALL cannot find
  "/builddir/build/BUILD/qzion-mainline/x86_64-redhat-linux-gnu/qzion.pc".
Call Stack (most recent call first):
  cmake_install.cmake:37 (INCLUDE)
make: *** [install/fast] Error 1
make: Leaving directory `/builddir/build/BUILD/qzion-mainline/x86_64-redhat-linux-gnu'
error: Bad exit status from /var/tmp/rpm-tmp.hqDQSm (%install)
RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.hqDQSm (%install)
Child returncode was: 1
EXCEPTION: Command failed. See logs for output.
 # ['bash', '--login', '-c', 'rpmbuild -bb --target x86_64 --nodeps builddir/build/SPECS/qzion.spec']
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/mock/trace_decorator.py", line 70, in trace
    result = func(*args, **kw)
  File "/usr/lib/python2.4/site-packages/mock/util.py", line 324, in do
    raise mock.exception.Error, ("Command failed. See logs for output.\n # %s" % (command,), child.returncode)
Error: Command failed. See logs for output.
 # ['bash', '--login', '-c', 'rpmbuild -bb --target x86_64 --nodeps builddir/build/SPECS/qzion.spec']
LEAVE do --> EXCEPTION RAISED


Maybe a cmake-2.8-ism ?
Comment 1 john5342 2010-01-09 09:51:42 EST
It would appear that cmake has indeed changed behavior. The problem line is:

configure_file(common/qzion.pc.cmake qzion.pc @ONLY)

In F12 and before qzion.pc was being put in ${CMAKE_BINARY_DIR} but in F13 it is being put in ${CMAKE_CURRENT_BINARY_DIR}. It's qzions fault though. In 2.6 the manual said "The Input and Output files have to have full paths." but it worked due to the implementation. Now it's just wrong.

Fixed in qzion-0.4.0-7.fc13

Note You need to log in before you can comment on or make changes to this bug.