Bug 553743 - python-boto rpm is missing s3put and sbadmin
Summary: python-boto rpm is missing s3put and sbadmin
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-boto
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Robert Scheck
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-08 19:42 UTC by Garrett Holmstrom
Modified: 2010-02-01 01:20 UTC (History)
2 users (show)

Fixed In Version: 1.9b-1.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-09 21:53:03 UTC


Attachments (Terms of Use)

Description Garrett Holmstrom 2010-01-08 19:42:26 UTC
Description of problem:
The rpm for python-boto is missing /usr/bin/s3put and /usr/bin/sdbadmin, located in boto-%{version}/bin in the tarball.  As far as I know these can just be copied into place during %install.

Version-Release number of selected component (if applicable):
python-boto-1.8d-1.fc12

How reproducible:
repoquery -l python-boto

Actual results:
boto-%{version}/bin/s3put and boto-%{version}/bin/sdbadmin are not copied into the build root.

Expected results:
/usr/bin/s3put
/usr/bin/sdbadmin

Comment 1 Robert Scheck 2010-01-09 19:51:22 UTC
Well, there are some more binaries shipped by default...are they useful, too?

/usr/bin/elbadmin
/usr/bin/fetch_file
/usr/bin/launch_instance
/usr/bin/list_instances
/usr/bin/s3put
/usr/bin/sdbadmin
/usr/bin/taskadmin

Comment 2 Garrett Holmstrom 2010-01-09 20:13:38 UTC
It wouldn't hurt as long as they don't conflict with anything.  I mentioned those two in particular because those are the only ones in version 1.8d; the rest are new.

Comment 3 Robert Scheck 2010-01-09 20:25:06 UTC
If you don't have objections, I would upgrade to 1.9b at the same time...

Comment 4 Garrett Holmstrom 2010-01-09 20:30:34 UTC
I have no problem with that.

Comment 5 Fedora Update System 2010-02-01 01:05:51 UTC
python-boto-1.9b-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2010-02-01 01:20:48 UTC
python-boto-1.9b-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.