Bug 55380 - initscripts doesn't work with nicknames
Summary: initscripts doesn't work with nicknames
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-30 16:58 UTC by Trond Eivind Glomsrxd
Modified: 2014-03-17 02:24 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-31 08:09:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2002:022 normal SHIPPED_LIVE New initscripts packages available for Red Hat Linux 7.2 2002-02-06 05:00:00 UTC

Description Trond Eivind Glomsrxd 2001-10-30 16:58:17 UTC
neat creates network devices with nicknames. The initscripts uses some of
the information to guess other filenames, which breaks device init.

Comment 1 Gert Dewit 2001-10-31 08:09:48 UTC
In the is_available function in the network-functions file the network
device gets modprobed with the module name.
This way one can't assing specific options to an interface using
"options alias module_options" notation in /etc/modules.conf

If one has 2 NIC's using the same module, one can't for instance force
100Mbit FDX on one interface and 100Mbit HDX on the other because only
options to the module are available.

Try this setup:
alias eth0 eepro100
alias eth1 eepro100
options eth0 options=48
options eth1 options=32


Comment 2 Bill Nottingham 2002-01-25 05:25:41 UTC
modprobe call fixed in 6.51-1; the use of $DEVICE/$REALDEVICE should have all
been fixed in 6.40.2-1.


Note You need to log in before you can comment on or make changes to this bug.