Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 55382 - reset does not reset to proper values (console login)
reset does not reset to proper values (console login)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: ncurses (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-30 12:20 EST by Bishop Clark
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-11 15:30:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bishop Clark 2001-10-30 12:20:01 EST
Description of Problem:
When using 'reset' to reset the console to sane settings, the command does 
not reset the console as per expectations, disabling ^D, ^C, and setting ^H 
to be Interrupt.

Version-Release number of selected component (if applicable):
5.2-12

How Reproducible:
Always

Steps to Reproduce:
1. run setup (it uses curses) and run the X config especially.
2. quit out of setup
3. run 'reset' on the command line

Actual Results:
Terminal characteristics are imprefectly reset - ^C, ^D, ^H, for example, 
all misbehave

Expected Results:
Terminal settings identical to login state.

Additional Information:

fresh install RH72.  No updates yet.  Will replicate on Upd RH72 if 
required, but no ncurses update was seen.
Comment 1 Bernhard Rosenkraenzer 2001-11-05 11:20:08 EST
The default values are: 
^C = Interrupt (Enabled) 
^D = Hangup (== logout in normal shells) (enabled) 
^H = Backspace 
 
And reset resets to just those. 
 
Comment 2 Bishop Clark 2001-11-05 16:20:38 EST
in THEORY, that should be the case. 

Do me a favour:  take 10 freakin' seconds, read the report, duplicate the problem and understand that SUCH ISN'T HAPPENING.

Please give me some indication that reporting bugs is NOT a  waste of my time.
Comment 3 Bernhard Rosenkraenzer 2001-11-05 16:28:58 EST
Sorry, I misunderstood your bug report - I read "the command does 
not reset the console as per expectations, disabling ^D, ^C, and setting ^H 
to be Interrupt" as "The command does not reset the console as per 
expectations, with the expectations being that ^D and ^C are disabled, and ^H 
is set to be Interrupt" (non-ambiguous bug reports are even less of a waste of 
time ;)) )

I've tried to reproduce this about 20 times by now, and still haven't seen the 
behavior you're describing.
What is $TERM set to?

Comment 4 Aaron Brown 2001-11-05 16:34:13 EST
Verified the following all worked after attempting bug
reporter's case:
 
^C = Interrupt (Enabled) 
^D = Hangup (== logout in normal shells) (enabled) 
^H = Backspace 

I verified this both with and without X.

Bishop, is there any other info you can send me about how
you have things set up?

Comment 5 Bishop Clark 2001-11-05 16:46:52 EST
certainly 

(bero - $TERM = linux )

It's a Compaq ProLiant 1600, dirt-common machine.    4.3Gb SCSI on the ncr-ish hot-swap bay, 256M in the box, single 400MHz processor.

RH72 is set up as a minimal server install, the only changes being a partition layout change:

   Device Boot    Start       End    Blocks   Id  System
/dev/sda1   *         1        17     17392   83  Linux
/dev/sda2            18      4094   4174848    5  Extended
/dev/sda5            18       146    132080   82  Linux swap
/dev/sda6           147      4094   4042736   83  Linux

[root@localhost linux]# mount
/dev/sda6 on / type ext3 (rw)
none on /proc type proc (rw)
none on /dev/pts type devpts (rw,gid=5,mode=620)
none on /dev/shm type tmpfs (rw)

Packages added since ISL:
 - tun
 - vtun
 - lzo

The problem occured before installation of those pkgs, tho.  What more do you wish to know?  Modules.conf?  rpm-qa?  anything, let me know.  The 
only thing I can't do is allow a login to that machine - the machine's behind three corp firewalls (no SYNs to the devel location) and is deadlinked 
because my IS can't get the route statement right.    SO, no ssh/etc, but almost anything else.  I HAVE some different hardware available to me, 
because, well, where I work, but I'd have to horsetrade for something.  If you want me to test on different HW, I can do this too.  Give me a 
standard-ish HW profile and I may be abel to match it.

Thanks for accepting my flame, more so for still looking at the issue.  I hate NOTABUGs that I can see plain as day.  8-\ 




Note You need to log in before you can comment on or make changes to this bug.