Bug 55384 - PCMCIA Cards isn't in the Ethernet list.
PCMCIA Cards isn't in the Ethernet list.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-30 12:22 EST by Yuhanes Tjandra
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-11 11:12:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yuhanes Tjandra 2001-10-30 12:22:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:
After installing RH 7.2, the pcmcia isn't recognized. The modem, however, 
is detected as a generic modem. The Ethernet isn't detected. This problem 
isn't occured when I used RH 7.1

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Installing RH 7.2.
2.Successfully Installed
3.The PCMCIA isn't recognized
	

Additional info:
Comment 1 David Lawrence 2001-10-30 12:27:09 EST
We will need to know the exact brand and model number of the PCMCIA card you are
using. Changing component to kernel-pcmcia-cs.
Comment 2 Arjan van de Ven 2001-10-30 12:28:53 EST
can you run "cardctl ident" so see which card it is ?
Comment 3 Yuhanes Tjandra 2001-10-30 12:40:05 EST
The card is "Etherfast 10/100 + 56K Modem PC Card" Model No. PCMLM56. When I 
see the list at .etc/pcmcia/config, it's there under multipurpose card. 
However, it isn't recognized. When I tried to add ethernet adapter, my card 
wasn't in the list. 
This problem isn't happened when I used RH 7.1.
Comment 4 Yuhanes Tjandra 2001-10-30 12:43:04 EST
Forgot to mention the brandname, it's "Linksys"
Comment 5 John Burke 2001-11-01 15:00:47 EST
I am having the same problem.  I installed RH 7.2 on a Gateway Solo 9100 and my 3Com EtherLink III PCMCIA 3C589C ethernet card was not in 
the ethernet list in the NEAT.  When I tried to use the EtherLink III entry that was in the list, I got a box that said that the card could not be initialized 
and that I should check my settings.  It looks like no 3Com PCMCIA cards are in the list, and the 3c589 driver is not in the directory where all of the 
other drivers are, although it is in the pcmcia directory.

I had no problems running with this card on RH 7.1.  Also, on 7.2, cardctl sees the card with no problem.

John Burke

Comment 6 Arjan van de Ven 2001-11-02 04:40:46 EST
jburke@sound.net:
I _really_ need exact "cardctl ident" output in order to see where it goes wrong...
Comment 7 John Burke 2001-11-02 10:18:35 EST
The cardctl ident output is:
Socket 0:
    product info: "3Com Corporation",  "3C589", "TP/BNC LAN Card Ver. 2a", "000002"
    manfid: 0x0101, 0x0589
    function: 6 (network)
Socket 1:
    product info: "Zoom Telephonics, Inc.", "PCMCIA 56K LT DataFax"
    manfid: 0x0200, 0x0001
    function: 2 (serial)
Comment 8 Yuhanes Tjandra 2001-11-02 14:25:17 EST
Here is mine:
socket 0:
no product info available
Socket 1:
product info: "Linksys", "EtherFast 10&100 + 56K PC Card (PCMLM56)"
manfid: 0x0143, 0xc0ab
function: 0 (multifunction)
(That was done by performing the command "cardctl ident")

(this one using the command "cardctl status")
Socket 0:
no card
Socket 1:
5V 16-bit PC Card
function 0: [busy]

(This one using the command "cardctl config")
Socket 0:
not configured
Socket 1:
Vcc 5.0V Vpp1 0.0V Vpp2 0.0V
interface type is "memory and I/O"
irq 3 [shared] [level]
speaker output is enabled
function 0:
config base 0xffe0
option 0x43 status 0x08 pin 0x00
io 0x0300-0x031f [auto]
io 0x02f8-0x02ff [8bit]
Comment 9 Arjan van de Ven 2001-11-05 04:45:14 EST
Is there any output in the syslog (/var/log/messages) that looks useful ? In
doubt, please attach the last 30 lines of that file when you insert that
card....
Comment 10 Yuhanes Tjandra 2001-11-05 10:43:43 EST
This is the part of /var/log/messages (the one that has something to do with 
PCMCIA). There is an error on the fourth line, probably that's the problem. 
Nov  5 17:13:58 localhost pcmcia:  cardmgr.
Nov  5 17:13:58 localhost cardmgr[784]: starting, version is 3.1.22
Nov  5 17:13:58 localhost rc: Starting pcmcia:  succeeded
Nov  5 17:13:58 localhost cardmgr[784]: config error, file './config.opts' line 
8: no function bindings
Nov  5 17:13:58 localhost cardmgr[784]: watching 2 sockets
Nov  5 17:13:58 localhost kernel: cs: IO port probe 0x0c00-0x0cff: clean.
Nov  5 17:13:58 localhost kernel: cs: IO port probe 0x0100-0x04ff: excluding 
0x220-0x22f 0x330-0x337 0x378-0x37f 0x388-0x38f 0x398-0x39f 0x4d0-0x4d7
Nov  5 17:13:58 localhost kernel: cs: IO port probe 0x0a00-0x0aff: clean.
Nov  5 17:13:58 localhost cardmgr[784]: initializing socket 1
Nov  5 17:13:58 localhost kernel: cs: memory probe 0xa0000000-0xa0ffffff: clean.
Nov  5 17:13:58 localhost cardmgr[784]: socket 1: Linksys EtherFast LANmodem 56K
Nov  5 17:13:58 localhost cardmgr[784]: executing: 'modprobe 8390'
Nov  5 17:13:58 localhost cardmgr[784]: executing: 'modprobe pcnet_cs'
Nov  5 17:13:58 localhost cardmgr[784]: executing: 'modprobe serial_cs'
Nov  5 17:13:59 localhost kernel: eth0: NE2000 (DL10022 rev 05): io 0x300, irq 
3, hw_addr 00:E0:98:8F:51:39
Nov  5 17:13:59 localhost kernel: ttyS01 at port 0x02f8 (irq = 3) is a 16550A
Nov  5 17:13:59 localhost cardmgr[784]: executing: './network start eth0'
Nov  5 17:13:59 localhost cardmgr[784]: executing: './serial start ttyS1'
Comment 11 John Burke 2001-11-05 10:59:02 EST
Here is the /var/log/messages when I insert the ethernet card:

Nov  5 09:47:31 localhost cardmgr[859]: initializing socket 0
Nov  5 09:47:31 localhost cardmgr[859]: socket 0: 3Com 589 Ethernet
Nov  5 09:47:31 localhost cardmgr[859]: executing: 'modprobe 3c589_cs'
Nov  5 09:47:31 localhost cardmgr[859]: executing: './network start eth0'
Nov  5 09:47:31 localhost kernel: eth0: 3Com 3c589, io 0x300, irq 10, hw_addr 00:A0:24:A5:48:4D
Nov  5 09:47:31 localhost kernel:   8K FIFO split 5:3 Rx:Tx, auto xcvr

Comment 12 Yuhanes Tjandra 2001-11-17 11:57:33 EST
I just tried my luck to choose one of the card in the list, guess what? My DSL
connection works!!! 
Here is how I got it works: 
I chose any cards in the list. (I chose W8003 and w8013 compatible ...) and
filled in the username and the password for my DSL account. 
The network configuration, though, complains that it can't verify the card. I
activated the eth0 interface, yet it generated an error message something like
"failed to activate the interface". But the connection was already there. The
connection was actually successful.
Comment 13 John Burke 2001-11-17 16:00:30 EST
How did you 'activate the eth0 interface?'  I picked the same item in the list that you did and got the same 'cannot initialize the card' message I 
received when I tried other cards before.  But I didn't know where to go from there to activate the ethernet, and the light on my ethernet box never 
came on to indicate that there was a connection.  I have a cable modem instead of DSL, but that shouldn't make any difference regarding the 
ethernet connection.  Any help you can give would be appreciated.

Thanks.
Comment 14 Yuhanes Tjandra 2001-11-19 09:41:55 EST
looks like I forgot to sign in when I sent this e-mail before. Got to type it 
again then. Okay, here I got it works. I set up my ethernet card thru 
the "internet configuration wizards" There I chose the card and filled my 
username and password. Then I used the RH network monitor, and there was the 
new connection interface, which was "ppp0". I dialed it, and there was an error 
message "failed to activate the interface". The connection, however, was 
successful. I was wondering then that the problem isn't the kernel pcmcia. I 
think the cause is the software "Internet-config"
Comment 15 John Burke 2001-11-26 10:29:24 EST
I'm afraid that mine still doesn't work.  I can't bring the ethernet up no matter what I try.  Can someone at RedHat give us a status on this, as we 
haven't heard anything for several weeks and I can see by posts to the installation forum that we are not the only ones with this problem.

Thanks.
Comment 16 Yuhanes Tjandra 2001-11-26 10:56:35 EST
This is the latest development from me: After struggling for a while,now I can 
connect my computer to the internet without any problem. I didn't use the 
software that RH provided to configure the internet connection. Instead I use 
rp-pppoe for my connection. In order to do that, I have to download the latest 
rp-pppoe. the rp-pppoe which is already provided doesn't work at all. (Note: I 
think PPPoE works only for adsl connection) The good thing about the newest rp-
pppoe is that it has a GUI. Therefore, I am pretty sure that the main problem 
is the software package "RH internet-config" instead of the "kernel pcmcia". 
FYI John, if you can see your pcmcia card by using this command "ifconfig ethX" 
(X is the number of card), your pcmcia card is basically fine. There should be 
the hwaddress (hardware address) when you type that command. If you have 
further questions, you can ask me directly. I am not the expert though, but at 
least I can give some inputs :).
Comment 17 John Burke 2001-12-11 11:12:48 EST
I was finally able to get it to work merely by typing "ifconfig eth0 up".  The light on my ethernet hub came on immediately, so the NEAT is apparantly 
not needed for this card. For reasons I don't understand, I only have to do this once.   After adding a /etc/sysconfig/network-scripts/ifcfg-eth0 file 
containing
   DEVICE=eth0
   BOOTPROTO=dhcp
   ONBOOT=yes
my cable modem worked too.  Thanks for your help

Note You need to log in before you can comment on or make changes to this bug.