Bug 55390 - error when rebuild php-4.0.6-9 from php.spec
Summary: error when rebuild php-4.0.6-9 from php.spec
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: autoconf   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-30 18:13 UTC by Need Real Name
Modified: 2007-04-18 16:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-09 01:56:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-10-30 18:13:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpm -ba php.spec
2.
3.
	

Actual Results:  ???????????(%prep): /bin/sh -e /var/tmp/rpm-tmp.98581
/usr/src/redhat/BUILD/php-4.0.6/php-4.0.6 /usr/src/redhat/BUILD/php-4.0.6
Patch #0 (php-4.0.6-redhat.patch):
Patch #1 (php-4.0.3-required.patch):
Patch #2 (php-4.0.4pl1-linkage.patch):
Patch #3 (php-4.0.6-libtool.patch):
Patch #4 (php-4.0.5-db.patch):
Patch #5 (php-4.0.5-ext.patch):
Patch #6 (php-4.0.6-ZVAL.patch):
`/usr/lib/c-client.a' -> `ext/imap/lib/libc-client.a'
buildconf: checking installation...
buildconf: autoconf version 2.52 (ok)
buildconf: automake version 1.5 (ok)
buildconf: libtool version 1.4 (ok)
rebuilding Makefile templates
automake: configure.in: installing `./ylwrap'
rebuilding configure
aclocal.m4:814: error: m4_defn: undefined macro: _m4_divert_diversion
aclocal.m4:360: PHP_SUBST is expanded from...
aclocal.m4:814: the top level
/usr/src/redhat/BUILD/php-4.0.6
???????????(%build): /bin/sh -e /var/tmp/rpm-tmp.99122
/usr/src/redhat/BUILD/php-4.0.6/php-4.0.6-cgi /usr/src/redhat/BUILD/php-4.0.6
Using `AC_PROG_RANLIB' is rendered obsolete by `AC_PROG_LIBTOOL'
You should update your `aclocal.m4' by running aclocal.



Additional info:

Comment 1 Need Real Name 2001-11-19 17:00:05 UTC
Autoconf 2.52 (2.52f) don`t produce configure from configure.in for php4.0.6 ant
php4.1.0RC2: PHP_SUBST undefined macros.

When i reinstall autoconf 2.13 back this work fine.


PHP-DEV recomend reinstall autoconf 2.52 to 2.13.



Comment 2 Phil Copeland 2002-01-08 16:59:39 UTC
Humm this seems to be related to autoconf but I'm afraid I'm not that
knowledgeable in this area I've passed this over to the autoconf owner to see if
he has any ideas as it certainly compiles fine with 7.2's autoconf-2.13

Phil
=--=

Comment 3 Jens Petersen 2002-01-09 01:56:20 UTC
Which version-release of php?

I don't see this with php-4.0.6-13, autoconf-2.52-5, automake-1.5-1,
libtool-1.4.2-3 from rawhide.


Comment 4 Jens Petersen 2002-01-09 05:42:24 UTC
Ah, I see: php-4.0.6-9.  Could you try a newer php src rpm package?



Note You need to log in before you can comment on or make changes to this bug.