This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 553902 - Review Request: rubygem-gemcutter - The gemcutter client gem
Review Request: rubygem-gemcutter - The gemcutter client gem
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ruben Kerkhof
Fedora Extras Quality Assurance
:
Depends On: 553908
Blocks: 553898
  Show dependency treegraph
 
Reported: 2010-01-09 07:29 EST by Jeroen van Meeuwen
Modified: 2010-05-03 20:25 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.3.0-2.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-16 21:54:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
ruben: fedora‑review+
tibbs: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Jeroen van Meeuwen 2010-01-09 07:29:06 EST
Spec URL: http://www.kanarip.com/custom/SPECS/rubygem-gemcutter.spec
SRPM URL: http://www.kanarip.com/custom/f12/SRPMS/rubygem-gemcutter-0.3.0-1.fc12.src.rpm
Description: The gemcutter client gem that interacts with the site http://gemcutter.org
Comment 1 Ruben Kerkhof 2010-01-09 10:59:52 EST
Hi Jeroen,

Please have a look at the rpmlint output:

[ruben@slice SPECS]$ rpmlint ../RPMS/noarch/rubygem-gemcutter-0.3.0-1.fc13.noarch.rpm 
rubygem-gemcutter.noarch: W: incoherent-version-in-changelog 0.1.7-1 ['0.3.0-1.fc13', '0.3.0-1']
rubygem-gemcutter.noarch: W: wrong-file-end-of-line-encoding /usr/lib/ruby/gems/1.8/gems/gemcutter-0.3.0/MIT-LICENSE
rubygem-gemcutter.noarch: W: misspelled-macro /usr/lib/ruby/gems/1.8/doc/gemcutter-0.3.0/ri/Gem/AbstractCommand/api_key%3d-i.yaml %3d
rubygem-gemcutter.noarch: W: misspelled-macro /usr/lib/ruby/gems/1.8/doc/gemcutter-0.3.0/ri/Gem/AbstractCommand/use_proxy%21-i.yaml %21
1 packages and 0 specfiles checked; 0 errors, 4 warnings.
[ruben@slice SPECS]$ rpmlint ../SRPMS/rubygem-gemcutter-0.3.0-1.fc13.src.rpm 
rubygem-gemcutter.src: W: strange-permission rubygem-gemcutter.spec 0640L
1 packages and 0 specfiles checked; 0 errors, 1 warnings.
Comment 3 Ruben Kerkhof 2010-01-09 14:07:06 EST
Thanks, I did a quick test and the package works fine.

I don't see any other issues, so this package is approved.
Comment 4 Jeroen van Meeuwen 2010-01-09 21:09:03 EST
New Package CVS Request
=======================
Package Name: rubygem-gemcutter
Short Description: The gemcutter client gem
Owners: kanarip
Branches: EL-5 F-11 F-12 devel
InitialCC:
Comment 5 Jason Tibbitts 2010-01-13 13:03:54 EST
CVS done (by process-cvs-requests.py)
Comment 6 Fedora Update System 2010-01-16 08:43:52 EST
rubygem-gemcutter-0.3.0-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/rubygem-gemcutter-0.3.0-2.fc11
Comment 7 Fedora Update System 2010-01-16 21:54:09 EST
rubygem-gemcutter-0.3.0-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Michael Stahnke 2010-05-03 20:25:02 EDT
Is there a reason that this package is branched for EPEL 5 but not built?  If you need a co-maintainer I would be happy to maintain it.

Note You need to log in before you can comment on or make changes to this bug.