Bug 55396 - rpm 4.0.2 database queries dies in header.c:241
rpm 4.0.2 database queries dies in header.c:241
Status: CLOSED DUPLICATE of bug 38454
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Depends On:
  Show dependency treegraph
Reported: 2001-10-30 14:42 EST by bugzilla.com
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-10-30 14:42:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description bugzilla.com 2001-10-30 14:42:34 EST
Description of Problem:
installed rpm4.0.2 on my RH6.2 box.  I can install new packages fine, but
anything that tries to read from the package database dumps core:

[root@xerxes rpm]# rpm --rebuilddb
rpmdb: header.c:241: regionSwab: Assertion `ie.info.type >= 0 &&
ie.info.type <= 9' failed.
Aborted (core dumped)

Version-Release number of selected component (if applicable):
rpm 4.0.2

How Reproducible:
Every time.

Steps to Reproduce:
1.  Be running RH6.2
2.  Be using rpm4.0.2
3.  rpm -q -a  *or* rpm --rebuilddb
Those are the two I've noticed it with.

Actual Results:
Aborted (core dumped)

Expected Results:
I should have received rpm database query results.

Additional Information:
Yes, I've noticed that this bears a striking resemblance to Bug# 38454.  I
tried what was recommended to fix that, but that seems to be specific to
RH7.x builds.  The proposed fix mentions doing some things with
/var/lib/rpm/Packages, but this file/directory does not exist.  I'm
guessing that this is specific to RH6.x...
Comment 1 Jeff Johnson 2001-11-04 10:51:20 EST
The fix is the same on 6.x, but you will need the
db3-utils-3.2.9 package for Red Hat 6.x installed.
This is availbale through Errata/Updates as well as at

*** This bug has been marked as a duplicate of 38454 ***

Note You need to log in before you can comment on or make changes to this bug.