Bug 554145 - Directory for storing configuration files is missing
Directory for storing configuration files is missing
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: lxc (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Silas Sewell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-10 12:33 EST by Robin Green
Modified: 2010-02-18 01:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-18 01:45:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Green 2010-01-10 12:33:03 EST
Description of problem:
lxc-create cannot create containers: it just says "no configuration path defined !"

Version-Release number of selected component (if applicable):
lxc-0.6.4-1.fc13.i686

How reproducible:
Always

Steps to Reproduce:
1. create a configuration file, lxc.conf
2. sudo lxc-create -n bug -f lxc.conf
  
Actual results:
"no configuration path defined !"

Expected results:
Successful container creation

Additional info:
The lxc RPM needs to create the directory /var/lib/nxc
Comment 1 Silas Sewell 2010-02-18 00:40:33 EST
I wasn't able to reproduce this, if you want to attach you're lxc.conf file I'll have a look.

I just built 0.6.5 so you might try that (I included the /var/lib/lxc directory).
Comment 2 Silas Sewell 2010-02-18 01:45:45 EST
It looks like you got this working since you submitted 554164, so I'm closing.

P.S. In your title you referrer to a "Directory for storing configuration" which I assume you mean the old /etc/lxc which was removed upstream in 0.6.4. There is no real sensible defaults for such a directory, so I'm deferring to upstreams decision.

Note You need to log in before you can comment on or make changes to this bug.