This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 554217 - WARNING: mismatch_cnt is not 0 on /dev/md0
WARNING: mismatch_cnt is not 0 on /dev/md0
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mdadm (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Doug Ledford
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-10 18:46 EST by Ray Todd Stevens
Modified: 2010-05-02 14:45 EDT (History)
4 users (show)

See Also:
Fixed In Version: initscripts-9.09-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-19 14:40:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ray Todd Stevens 2010-01-10 18:46:31 EST
Ever since I upgraded from fc11 to fc12 I keep getting this

WARNING: mismatch_cnt is not 0 on /dev/md0

on several of my servers.

/dev/md0 is my root  ("/")

I can fix it with a great deal of effort, but it keeps coming back.
Comment 1 Patrick C. F. Ernzer 2010-01-24 12:21:40 EST
Same error but
/dev/md0 on /boot type ext3 (rw)

the below fixes it;
[root@morn ~]# echo repair > /sys/devices/virtual/block/md0/md/sync_action
[root@morn ~]# echo check > /sys/devices/virtual/block/md0/md/sync_action
[root@morn ~]# cat /sys/devices/virtual/block/md0/md/mismatch_cnt
0

But like the reporter said, it keeps coming back.

FWIW, mo0 is a RAID1 made up of sda1, sdb1 and sdc1
Comment 2 Ray Todd Stevens 2010-01-24 16:15:06 EST
And it is still happening at my site.

I now have 

3 which are about every week doing this with md0 = root
2 which have a md0 that is /boot and md1 that is root with only the problem on md0
1 with md10 that is /boot and md1 that is root which is giving the error for both.

I also have a couple that are not giving problems, but most are.
Comment 3 Doug Ledford 2010-02-19 14:40:07 EST

*** This bug has been marked as a duplicate of bug 547128 ***
Comment 4 Fedora Update System 2010-04-09 16:13:01 EDT
mdadm-3.1.2-9.fc13,initscripts-9.09-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/mdadm-3.1.2-9.fc13,initscripts-9.09-1.fc13
Comment 5 Fedora Update System 2010-04-27 23:08:33 EDT
initscripts-9.09-1.fc13, mdadm-3.1.2-10.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Gaetan Cambier 2010-05-02 14:45:12 EDT
this bug is not solved for fedora 12 ?

Note You need to log in before you can comment on or make changes to this bug.