Bug 55423 - RFE: Installer doesn't allow eject of CD for user remedy upon read failure
RFE: Installer doesn't allow eject of CD for user remedy upon read failure
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-30 19:13 EST by Neil Padgett
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neil Padgett 2001-10-30 19:13:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.9-6 i686)

Description of problem:
When using the installer, should a disk read error occur when attempting to
install a package, a dialog is displayed explaining the circumstances to
the user. (The dialog correctly suggesting possibility of bad media, dirty
CD, etc.) A single option to acknowledge and retry is presented. 

However, the CD cannot be ejected for cleaning / inspection by the user, as
it is mounted. Hence, the user cannot likely remedy the failure situation,
and is forced to restart the installation process completely.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Dirty CD 2 of your disc set. (Disc 1 may also be dirtied, but for ease
of reproduction it is better to dirty Disc 1.)
2. Perform a full install. (Which guarantees the dirty spot should get
hit.)
3. Attempt to eject the CD to clean it when a read error is reported.
	

Actual Results:  The CD is currently mounted and cannot be ejected.

Expected Results:  The CD should be umounted before the error dialog is
raised. This will allow the user to clean / replace the CD before retrying.
After the dialog is dismissed the CD should be remounted.

Additional info:

This bug is similar to 35081 and 25724. However, the request is _not_ for a
feature enhancement to allow a package to be skipped. Instead the request
is for the installer to have the behaviour one would likely expect -- when
reporting a possibly dirty CD, the user should have the opportunity to
clean the problem CD before retrying.
Comment 1 Brent Fox 2001-10-31 00:10:14 EST
Marking as an RFE.
Comment 2 Michael Fulbright 2002-03-21 11:43:32 EST
The CD most likely has fds held by rpmlib open so we can't unmount and eject.

Will need to rethink for our next release.
Comment 3 Michael Fulbright 2002-03-26 12:33:50 EST
Deferring to future release.
Comment 4 Red Hat Bugzilla 2006-02-21 13:48:13 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.