Bug 55425 - Insatller stops during upgrade, Unhandled exception
Insatller stops during upgrade, Unhandled exception
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-30 19:48 EST by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-02 11:48:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dump from anaconda (78.95 KB, text/plain)
2001-10-30 19:48 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-10-30 19:48:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.3) Gecko/20010801

Description of problem:
After most ( maybe all) of the packages had been installed, a dialong
appeared stating that an Unhandeled Exception had occurred and to post the
info in the window here. After having it dump the info to floppy, clicking
ok aborted the install and shutdown the system

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.Burn 7.2 cds from ISOs
2.try to upgrade from 7.1
3.
	

Actual Results:  Unhandeld Exception

Expected Results:  Continued install

Additional info:
Comment 1 Need Real Name 2001-10-30 19:48:58 EST
Created attachment 35801 [details]
dump from anaconda
Comment 2 Need Real Name 2001-10-30 20:36:40 EST
RH 7.1 system hosed by upgrade attempt. Attempt to perform full re-install gets
similar result.
Comment 3 Brent Fox 2001-10-30 23:25:05 EST
At any point in the install, did you switch to VC2 and go into the /mnt/sysimage
directory?
Comment 4 Need Real Name 2001-10-31 10:15:40 EST
no I didn't do any console switching. But I can try again and do that if it will
gain useful info.
Comment 5 Brent Fox 2001-10-31 11:30:06 EST
No, don't do that.  :)  When people do that, and don't leave the /mnt/sysimage
directory, the kernel will be unable to unmount the hard drive from the
filesystem because it is in use.

Some process is still holding a file that prevent the device from being
unmounted, but I don't know what it is without really having access to the
machine in order to look around in /proc.  We have heard reports of this before,
but have not been able to reproduce it in house.

Did the upgrade leave your system in a usable state?
Comment 6 Need Real Name 2001-10-31 12:34:35 EST
No, Linux won't boot. It would only go to LI
I'm running dual boot right now, so my system is useable.
There was an dialog midway through the process stating that it could not read a
certain RPM. (seems odd since this was a just unwrapped cd-r) After a couple of
tries it either worked or skipped it. Could this file still be open?
Comment 7 Need Real Name 2001-10-31 22:36:48 EST
Ok, I re-burned the first CD, and it installed fine. Must have been a burning
glitch. However the ysytem still does not boot. I keep getting severe errors
during the disk scanning phase that freeses the system. Some form of kernel OOPS
error.
Comment 8 Brent Fox 2001-11-01 16:31:04 EST
Weird.  Did you check the md5sums of the ISOs before you burned them?  You are
seeing some pretty strange stuff.
Comment 9 Need Real Name 2001-11-02 11:48:52 EST
I did not check the isos but i have fixed the problem. By booting with the
noathlon  flag then upgrading the kernel. I looked about and seems some other
people with thunderbird chips ahve the same problem. now booting fine.
Comment 10 Brent Fox 2001-11-03 15:56:23 EST
Ok.  Yes, there seems to be some Thunderbird weirdness.  My Athlon is
pre-Thunderbird, so I haven't seen it.  I'm closing this bug since you have
found a workaround.

Note You need to log in before you can comment on or make changes to this bug.