Bug 55434 - unaligned traps in kernel
unaligned traps in kernel
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-30 23:01 EST by Bill Nottingham
Modified: 2014-03-16 22:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-30 23:01:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2001-10-30 23:01:08 EST
I noticed this while poking around:

[notting@wierzbowski: ~]$ cat /proc/unalignedinfo 
Last userland trap : Last kernel trap   : kernel unaligned access to
0xe00000005de1f1d6, ip=0xe000000004770c31
Kernel trap count  : 48

ip decodes to (if I'm reading it right) tcp_parse_options.

2.4.9-7.2smp. Will install -11 and see if it persists.
Comment 1 Arjan van de Ven 2001-10-31 02:47:28 EST
THis is not a bug; there's some places in the tcp/ip stack that in rare
occasions will do an unaligned access. "fixing" those is not an option as that
would slow down very hot paths.

Note You need to log in before you can comment on or make changes to this bug.