Bug 55438 - Running kisdndock in Gnome causes X-logins to fail
Running kisdndock in Gnome causes X-logins to fail
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: isdn4k-utils (Show other bugs)
7.2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-31 02:46 EST by Stein Andersen
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-04 16:20:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stein Andersen 2001-10-31 02:46:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.5) Gecko/20011011

Description of problem:
Since there is no isdn-dialer for Gnome (that I have found), I have to use
kisdndock. This works, except that kisdndock changes the owner of my
.ICEauthority-file to root.root, causing that I can't login in X anymore,
until i change the ownership of that file back to mylogin.mylogin. When
starting kisdndock as root, everything works OK (I guess it's ok that
root's files are owned by root ;-). It also works fine in KDE, OR when I
have logged in with KDE, logged out, and then in again with Gnome.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Login using the Gnome desktop environment
2.start kisdndock 
3.Logout
	

Actual Results:  It's impossible to log in in X. X attempts to start, but
resets and falls back to the login prompt. I think this is because of
kisdndock having changed the ownership of ~/mylogin/.ICEauthority to
root.root, with read and write for owner at the only set permissions. At
least it works again when i change the ownership of this file back.

Expected Results:  I should have been able to log in just as usual.

Additional info:

There ought to be a simple isdn-dialer for Gnome as well as for KDE.
Comment 1 Ngo Than 2001-10-31 07:58:41 EST
did you start kisdndock as root? if yes, please try to start it as noonroot, i
hope this should work
Comment 2 Stein Andersen 2001-10-31 08:32:18 EST
I first started it as myself, and then kisdndock changed the ownership of my
.ICEauthority to root.root, so I couldn't log in the next time i tried. When I
start kisdndock as root, it works fine... Kisdndock _itself_ works fine if I
start it as myself as well, but as I said, it changes the permissions on
.ICEauthority so I can't log in until I change it back. If I log in with KDE, it
works fine both ways. Something is not working right when running kisdndock in
Gnome. When I do this, kisdndock demands that .ICEauthority is owned by root.
(..and that is what causes the problem, as far as I can understand.)
Comment 3 Ngo Than 2002-06-26 16:33:23 EDT
it's fixed in 7.3 release
Comment 4 Bill Nottingham 2006-08-04 16:20:13 EDT
Red Hat Linux and Red Hat Powertools are currently no longer supported by Red
Hat, Inc. In an effort to clean up bugzilla, we are closing all bugs in MODIFIED
state for these products.

However, we do want to make sure that nothing important slips through the
cracks. If, in fact, these issues are not resolved in a current Fedora Core
Release (such as Fedora Core 5), please open a new issues stating so. Thanks.

Note You need to log in before you can comment on or make changes to this bug.