Bug 554424 - KMS:RV620 GPU Lockup
Summary: KMS:RV620 GPU Lockup
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-11 17:20 UTC by António Lima
Modified: 2010-11-05 19:02 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-05 19:02:50 UTC
Type: ---


Attachments (Terms of Use)
lspci (19.26 KB, text/plain)
2010-01-11 17:20 UTC, António Lima
no flags Details
xorg.conf (1022 bytes, text/plain)
2010-01-11 17:21 UTC, António Lima
no flags Details
Xorg log (53.29 KB, text/plain)
2010-01-11 17:21 UTC, António Lima
no flags Details
dmesg (41.00 KB, text/plain)
2010-01-14 16:08 UTC, António Lima
no flags Details
Xorg.0.log.old (64.89 KB, text/plain)
2010-01-27 12:46 UTC, António Lima
no flags Details
dmesg after reboot (44.76 KB, text/plain)
2010-01-27 12:47 UTC, António Lima
no flags Details
dmesg after the crash, before reboot (56.32 KB, text/plain)
2010-01-31 22:58 UTC, Scott Schmit
no flags Details
piece of messages log - after crash (10.00 KB, text/plain)
2010-02-04 18:52 UTC, Wojciech Kicior
no flags Details

Description António Lima 2010-01-11 17:20:36 UTC
Created attachment 383028 [details]
lspci

Since Fedora 12 release I'm experiencing a lockup with KMS enabled with the radeon driver. 

The screen turns totally dark and I can't switch to a tty. The backlight is on but there is no visual output.

Here goes my xorg.conf and xorg0.log (before the lock) and lspci

Can I provide further info?

Comment 1 António Lima 2010-01-11 17:21:04 UTC
Created attachment 383029 [details]
xorg.conf

Comment 2 António Lima 2010-01-11 17:21:34 UTC
Created attachment 383030 [details]
Xorg log

Comment 3 Jérôme Glisse 2010-01-13 16:22:58 UTC
Please attach full dmesg after lock, you will need to log in through ssh to get it.

Comment 4 António Lima 2010-01-13 22:44:15 UTC
I've been using the driver with KMS for more then 4 hours now and still no lockup... weird. I think it my lock again so can you please keep the bug open for a few more days? If it does I'll attach the dmesg ASAP.

It usually locks up after a few minutes (pretty random but never took so long), so it's strange it hasn't locked yet..

Comment 5 António Lima 2010-01-14 16:08:34 UTC
Created attachment 383709 [details]
dmesg

As I expected, today I started having frequent locks. I'm attaching dmesg, hope there's something useful there. Had to ssh with my mobile phone, tricky :).

Comment 6 Jérôme Glisse 2010-01-14 18:14:13 UTC
This dmesg is after a reboot ? There is no message about any issue in it.

Comment 7 Jérôme Glisse 2010-01-14 18:15:01 UTC
Also, do you have desktop effect enabled ? Do you use any GL application ?

Comment 8 António Lima 2010-01-14 18:27:41 UTC
The dmesg is not after a reboot, the system was locked when I sshd it cand copied dmesg. I don't have desktop effects, only metacity with composite.

Comment 9 Milan Kerslager 2010-01-27 06:29:58 UTC
Look at /var/log/Xorg.0.log after the crash.

Comment 10 Jérôme Glisse 2010-01-27 10:08:28 UTC
Please attach full /var/log/messages after such crash (you can even reboot and copy /var/log/messages after the reboot)

Comment 11 Milan Kerslager 2010-01-27 11:23:49 UTC
(In reply to comment #9)
> Look at /var/log/Xorg.0.log after the crash.    

/var/log/Xorg.0.log.old after rebot and GUI again up

Comment 12 António Lima 2010-01-27 12:46:53 UTC
Created attachment 387055 [details]
Xorg.0.log.old

Comment 13 António Lima 2010-01-27 12:47:59 UTC
Created attachment 387056 [details]
dmesg after reboot

As requested here is the Xorg.0.log and the dmesg after reboot with GUI up and running.

Comment 14 António Lima 2010-01-27 22:31:37 UTC
I've been looking to the log files I attached this morning. I'm not by any means an expert in debugging X but the only thing suspicious I found was the last line of Xorg.0.log.old: 

(II) AIGLX: Suspending AIGLX clients for VT switch

I did no virtual terminal switch before the lockup so I this is suspicious. A quick google search lead me to this phoronix forum thread: 

http://www.phoronix.com/forums/showthread.php?t=14651

where a similar problem is discussed bit with an older version of Xorg. There is no workaround posted there. Hope this can be of any help.

Comment 15 Scott Schmit 2010-01-31 22:58:34 UTC
Created attachment 387909 [details]
dmesg after the crash, before reboot

I was able to capture the error in dmesg. Hope this helps.

Comment 16 Milan Kerslager 2010-02-02 18:41:42 UTC
Seems to be similar to bug #557805. Try use "nomodeset" kernel argument in Grub
(or radeon.modeset=0).

Comment 17 António Lima 2010-02-02 18:53:40 UTC
@Mila, that is, of course, what I do. The system is not usable otherwise.

The goal of the bug report is to try to fix the bug or at least fix it in next fedora version, so we can all enjoy KMS.

Comment 18 Milan Kerslager 2010-02-02 19:44:30 UTC
There are a lot of similar errors. It may be worth to zap them, post workarounds and make solid bugreport at https://bugs.freedesktop.org

Comment 19 Wojciech Kicior 2010-02-04 18:52:19 UTC
Created attachment 388867 [details]
piece of messages log - after crash

It seems I have the same problem on my ThinkPad R500, radeon HD 3400.
Can't even connect by ssh - I don't know why - it worked before.
running kernel with nomodeset parameter solves the problem, but something is wrong with suspend option then. Do you need any more logs from my machine?

Comment 20 Milan Kerslager 2010-03-02 06:24:39 UTC
There were some kernel updates but the X still crashes. Seems like no progress here since broken.

Comment 21 Milan Kerslager 2010-03-08 08:49:52 UTC
After latest DRM update (kernel + xorg-x11-drv-ati), the system still hardly
freezes with no traces in the log. Packages in the system:

kernel-2.6.32.9-67.fc12.x86_64
libdrm-2.4.17-1.fc12.i686
libdrm-2.4.17-1.fc12.x86_64
mesa-dri-drivers-7.7-3.fc12.i686
mesa-dri-drivers-7.7-3.fc12.x86_64
mesa-libGLU-7.7-3.fc12.i686
mesa-libGLU-7.7-3.fc12.x86_64
mesa-libGL-7.7-3.fc12.i686
mesa-libGL-7.7-3.fc12.x86_64
xorg-x11-drv-ati-6.13.0-0.21.20100219gite68d3a389.fc12.x86_64

Comment 22 Wojciech Kicior 2010-04-08 08:57:23 UTC
I forgot to add that (in my case) this started to happen after yum updates in January 2010. I don't remember exact date and xorg-x11-drv-ati version right now. Before, it all worked fine.

Comment 23 António Lima 2010-05-26 22:20:36 UTC
I'm on Fedora 13 and so far I had 2 GPU locks. They seem less frequent now, but this is still not fixed in this version :(.

The most anoying thing about not being able to use KMS is that suspend does not work...

Comment 24 António Lima 2010-05-26 22:28:14 UTC
EDIT suspend does work in F13 in nomodeset

Comment 25 Milan Kerslager 2010-05-27 09:34:35 UTC
F13 has far less lockups as written above. I have HD 2400 XT and KMS and sw suspend-to-disc both works.

However suspend-to-RAM does not work at all now.

Comment 26 António Lima 2010-05-30 11:54:00 UTC
I tried kernel 2.26.34 from rawhide and I haven't had any locks since then. 2.26.34 seems to fix this. Hope it gets to fedora updates.

I was also expecting to have more battery life with this kernel due to power management for ati cards in 2.26.34, but I don't notice any diference. But that's another issue :).

Comment 27 Wojciech Kicior 2010-06-02 13:05:02 UTC
I have not experienced any lockups since I upgraded to Fedora 13.
2.6.33.4-95.fc13.x86_64

Comment 28 Bug Zapper 2010-11-04 01:13:55 UTC
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.