Bug 55448 - (SCSI MEGARAID)Installation process fails to detect HP Netraid(megaraid) or Mylex Raid controllers
(SCSI MEGARAID)Installation process fails to detect HP Netraid(megaraid) or M...
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-10-31 09:41 EST by Greg LaPolla
Modified: 2008-08-01 12:22 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-30 11:39:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Greg LaPolla 2001-10-31 09:41:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
Installer will not detect megaraid or Mylex cards during the install 
process.  This system installs fine under RedHat 7.1 but fails to install 
or upgrade under 7.2.

System components:

SuperMicro P6DGU
1 PII 350 CPU
1 GB ECC Registered Ram
HP Netraid 1si  (megaraid)
External Compaq Raid Box 4 x ultra2 9 Gig Compaq HD's
1 4 gig Seagate ultrawide HD on the integrated Scsi controller (adaptec)
1 Quantum DLT7000 Tape drive on integrated scsi controller (adaptec)
1 50x IDE CD rom master on secondary channel
2 3Com 905B nic Cards
1 Riva128 AGP videocard (8megs)

Also tried with a Mylex Raid card (model number not known)  neither card 
was detected by the RedHat 7.2 Installer, the HP Netraid card is detected 
and functions perfectly under RedHat 7.1.  I did not try the mylex card 
under RedHat 7.1, But I can if you need that info.  

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Insert RedHat CD
2. Power Up and start installation

Actual Results:  Megaraid and Mylex Cards are not detected and drivers are 
not installed during installation.  The adaptec on-board controller is the 
only storage controller detected

Expected Results:  Raid controllers should be detected and drivers 

Additional info:
Comment 1 Need Real Name 2001-11-05 16:09:56 EST
I have an HP Netraid adapter that is detected, but no logical drives are found. 
This happens during a fresh install of redhat 7.2 or attempting to upgrade
Redhat 7.1 to Redhat 7.2.  The latest driver from HP 1.15 does not appear to
work with Redhat 7.2  Also, the latest kernel update for redhat 7.1 (2.4.9-12),
after it is installed, my system will not boot the kernel.  I receive a kernel
panic, no init found.  This same kernel panic happened with kernel update
(2.4.9-6).  This did not happen with kernel update (2.4.3-12).
Comment 2 Ed Marshall 2001-11-08 01:34:17 EST
I'm seeing the same problem here with a NetRaid 1si card in an HP NetServer 
LPr. Since all disks are driven by this card (two internal 18.2GB drives in a 
mirror set), installation fails as soon as anaconda notices that there's 
nothing to install to. I'm working on fashioning an updated driver disk for 
this, but would obviously rather see an updated driver disk from Red Hat. ;-)
Comment 3 Brent Fox 2001-11-08 23:07:31 EST
dkl, do we have the hardware necessary to test this?
Comment 4 Greg LaPolla 2001-11-09 23:26:32 EST
I have an extra netraid3 card with is just a 3 port version of the 1si card.  I 
would be willing to loan it if I can get a gurantee that it will be returned 
because it is a $2,000 card.
Comment 5 Ed Marshall 2001-11-23 04:07:50 EST
I've successfully created a driver disk which permits one to boot a Red Hat 
Linux 7.2 system on systems with NetRaid controllers (at least, with a NetRaid 
1si, which is my test system). It is available from:


The module has been compiled from the Matt Domsch's MegaRaid 1.18 source 
release from:


It Works For Me(tm). :-)
Comment 6 Greg LaPolla 2001-11-23 21:50:12 EST
I tried this driver disk. System updated perfectly without a hicth... Ok RedHat 
guys how did this slip through ?
Comment 7 Need Real Name 2001-11-26 13:00:29 EST
Anyone feel like making one of those disks for the Mylex DAC960 ?

The installer hangs on loading its driver with redhat 7.1 and 7.2.

What to do, what to do ?
Comment 8 Need Real Name 2001-11-26 18:55:52 EST
ok, I tested on an HP Netraid 1M adapter (supports 64 bit via firmware 
update).  Redhat 7.2 seen the controller and Raid set.  The UPGRADE from rh 7.1 
to 7.2 went fine.  The reboot however was messy.  Kernel Panic with try passing 
init= to the kernel messages.  My solution was to use rescue mode with the 
driver disk megaraid.img (see above notes).  This allowed me to mount the 
drives.  I then took the source code megaraid-1.18-tar.gz (see notes above)and 
compiled the modules on another machine running a default install of redhat 
7.2.  I then took the newly compiled modules and copied them 
to /lib/modules/2.4.7-10/kernel/drivers/scsi.  I made backup copies of the 
original files before I copied over them.  I then made a backup copy 
of /boot/initrd-2.4.7-10.img, then I deleted /boot/initrd-2.4.7-10.img.  I then 
issued the command /sbin/mkinitrd /boot/initrd-2.4.7-10.img 2.4.7-10 . I then 
rebooted and ALL WAS WELL.  The server came up just fine.  Just a side note, I 
originally installed with GRUB, but changed to LILO.  And I did convert from 
ext2 to ext3.  I'm going to try a kernel update next.  I expect it to fail with 
the same kernel panic.  I now know that I'll have to replace the megaraid.c and 
megaraid.h files in my source tree and rebuild a custom kernel probably for 
now.  I hope this has helped anyone out there using a Mylex or Netraid Adapter.
Comment 9 Jeremy Katz 2001-11-28 20:56:53 EST
Arjan -- any ideas as to what the problem is here?
Comment 10 Arjan van de Ven 2001-11-29 05:50:18 EST
Most likely the HP Megaraid firmware is outdated; we've seen problems in this
area before......
Comment 11 Greg LaPolla 2001-11-29 07:49:22 EST
How could this be the firmware ?  Using a driver disk works and the install 
works perfectly on 7.1.
Comment 12 Arjan van de Ven 2001-11-29 07:51:01 EST
the 1.18 driver has specific workarounds for certain versions of HP firmware....
Comment 13 Greg LaPolla 2001-11-29 19:02:05 EST
I understand that the 1.18 driver has workarounds, but this works under Redhat 
7.1 flawless.  Installs and runs fine no driver disk needed.
Comment 14 Need Real Name 2001-11-29 23:56:24 EST
The bios and firmware levels of the machine are currently the most recent 
revisions from HP.  Also when I performed my kernel update from 2.4.7-10 to 
2.4.9-13, I built the new kernel from source using the megaraid.c and 
megaraid.h from the 1.18 source.  The new kernel booted just fine after the 
Comment 15 Ed Marshall 2001-12-11 12:42:40 EST
I can confirm that I'm running the latest BIOS and firmware from HP for the 1si 
controller (BIOS 2.03, firmware 2.05). You can download the software bundles 
for the entire netRAID lineup from HP's website at:


For the record: I'd upgraded the firmware before trying to install Red Hat 
Linux 7.2. None of the 7.2 kernels ship with a working megaraid module for 
netRAID controllers. I'm a little concerned about the one I built from 1.18, as 
well; during bootup, it shows:

megaraid: [??? : ??? ] detected 1 logical drives
megaraid: channel[1] is raid.
scsi0 : AMI MegaRAID ??? 254 commands 16 targets 1 chans 8 luns

The "???" above are goofy characters (smiley faces, etc). Doesn't exactly 
inspire confidence. ;-)

When trying out the RH-supplied 2.4.9-13, the system boots, displays a 
recognition of the controller just as above (goofy characters and all), and 
hangs upon trying to mount the root filesystem, occasionally giving back scsi 
timeout errors.

This is probably a good time to also mention that there's another bugzilla 
entry, #47221, which appears to be a duplicate of this bug. Perhaps the 
component of this bug ought to be kernel as well, since this really boils down 
to the megaraid module as shipped with 2.4.7-10 not recognizing the netRAID 
controller, and 2.4.9-13 doing the "wrong thing" with it. ;-)
Comment 16 Need Real Name 2001-12-11 21:51:53 EST
I would agree that it is a kernel issue.  The one thing I don't think I 
mentioned is that I did not use the Red Hat RPM for the kernel 2.4.9-13.  I 
installed the RPM sources and compiled my own kernel.  I did however replace 
the redhat megaraid.c/megaraid.h sources files with those in the 1.18 driver 
listed above.  This allows the card to be properly detected, and eliminates the 
weird characters when loading the megaraid driver for my system when booting.  
I started receiving the weird characters in Red Hat 7.1 kernel 2.4.3-12, and if 
I tried to go above that kernel version, the megaraid driver failed to load.
Comment 17 Arjan van de Ven 2001-12-13 04:21:26 EST
I've made a new kernel RPM with the .18 megaraid driver:
Comment 18 Ed Marshall 2001-12-13 12:43:10 EST
Tried this kernel out. A couple of things:

. Mounting the root filesystem fails with the same scsi timeout I was seeing 
with my own kernel. So, for kicks, I started poking around the netRAID 
configuration menus (CTRL-M at bootup, just like MegaRAID controllers). There's 
a setting under Options|Adapter called "Emulation", which toggles between I2O 
and MASS STORAGE emulation. Changing from I2O to MASS STORAGE allowed me to 
boot. I'm assuming that's because of the next point...

. There's a bunch of new I2O stuff in this kernel that wasn't in 2.4.7-10. ;-) 
Is that possibly what's causing a bad interaction here?

. A quick search on google for "emulation I2O MASS STORAGE" after finding out 
that that particular setting worked came up with the following from SuSE:


Basically, they suggest making the same change I just found by trial and 
error. ;-) Doh.

Hopefully, this is enough information to help anyone else suffering from this.
Comment 19 Need Real Name 2001-12-13 23:54:22 EST
Just thought that I'd say the I2O option has been disabled on my card.  It has 
always been set to mass storage mode.  This is the DEFAULT setting for my 
Comment 20 Arjan van de Ven 2002-01-27 05:13:41 EST
Anyway the 2.4.9-21 kernel has megaraid 1.18...
As to the I2O.. yes that part is f*cked. The adapter *almost* succeeds in
emulating an i2o device ;(
Comment 21 Need Real Name 2002-04-09 11:39:55 EDT
The new Skipjack beta 2 has the same problem on HP LC 2000 with NetRaid-1Si 
It does not find hard drives on which to make partiotions and installation 
stops. The same is with RedHat 7.2.
RedHat 7.1 installs without problems.
This is specific to NetRaid-1Si  controller.
If we change the controller to NetRaid-1M, then the installation works ok,
at least with RedHat 7.2.

Other people have the same problem at
Comment 22 Arjan van de Ven 2002-04-10 04:35:53 EDT
1) did you disable I2O on the card ?
2) do you have the most recent firmware ?
Comment 23 Need Real Name 2002-04-10 06:41:42 EDT
1) Yes, I2O is disabled.
2) Firmware is latest (BIOS 2.03, firmware 2.05)
Comment 24 Bugzilla owner 2004-09-30 11:39:13 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.