Bug 5545 - Installer crashes with python bug when upgrading old system
Installer crashes with python bug when upgrading old system
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-04 20:03 EDT by redhat
Modified: 2015-01-07 18:38 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-04 13:00:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description redhat 1999-10-04 20:03:28 EDT
When installing RH 6.1 from the bootnet.img disk (NFS) and
choosing to Update my old system, the graphical installer
stops at the message 'Finding Package to Update'. Switching
to VT1, I see the following message (no cut/paste, so
forgive typing errors):

Traceback (innermost last):
  File "/usr/lib/python1.5/site-packages/gtk.py", line 120,
in __call__
    ret = apply(self.func, a)
  File "/usr/lib/python1.5/site-packages/gui.py", line 317,
in nextClicked
    next = self.currentScreen.getNext ()
  File "/usr/lib/python1.5/site-packages/iw/examine.py",
line 18, in getNext
    self.todo.upgradeFindPackages (self.root)
  File "/usr/lib/python1.5/site-packages/todo.py", line
1155, in
upgradeFindPackages
    packages = rpm.findUpgradeSet(self.hdList.hdlist,
self.instPath)
rpm.error: error during upgrade check


And that's pretty much it... Using FTP also crashes with a
python error, albeit one that says something about FTP
command "500 CWD " not understood..... I can try to type a
copy of that one too, but it's much MUCH longer....

The weird thing is, that the exact same bootdisk, from the
exact same install source, happily works through the same
point in the upgrade on the machine next to it.

I tried going through rpm -qai and remove all non-official
RedHat packages (ie: 6.0 or it's updates), but it still
fails on the exact same spot.

If there is any further information I can provide or tests
I can run, please do not hesistate to contact me.
Comment 1 vrossum 1999-10-08 10:04:59 EDT
I had the same problem, but was able to work around it.
The rpm database of the 6.0 had some conficts.
I rebuild the datebase and removed a conflicting package (an old kde
version). (I don;t know an easy way to see what the conflicts are...)
After that the upgrade worked.
Comment 2 ben.de.rydt 1999-10-15 14:33:59 EDT
Same here: clean RedHat 6.0 + updates
(everything non RedHat in /usr/local/)
Crashes on FTP-upgrade, second FTP-upgrade succeeds.
Comment 3 Jay Turner 1999-10-20 14:15:59 EDT
Did you by any chance have an NTFS partition on the system which you
were upgrading?  There is a known problem with this which will be
fixed in an errata release later this week.  See bug #5555 for more
details.  Reopen this bug if this does not related to your problem.
Comment 4 redhat 1999-10-20 15:03:59 EDT
No, I don't have any NTFS or anything, I have a 64MB swap partition
as hda1 and / on hda2...

It also fails when installing from the CD, which again works
remarkably well on the machine next to it (which has an identical
partition layout)

This also equally fails on my main server, having sda1 as a DELL
system partition, sda2 as /boot and sda3 as / (swap is on another HD,
but crashes whether or not it's in)

I have 'upgraded' the machine this first was a problem on by clean
installing RH6.1 and copying my personal config and utilities from
the backup.. But this is still an issue for my main server, on which
such a "hack" procedure would result in too much downtime.

If there is anything I can do to help you debug and resolve this,
please let me know.


------- Additional Comments From   10/20/99 18:20 -------
No, I don't have an NTFS partition.  I have a Windows 95 (FAT16) on
hda1, 64MB swap partition on hda2 and / on hda3.  This is very similar
to the setup I have at home except I have /home on hda4.  It upgraded
with no problems.  I don't know if the Windows partition is FAT16 or
FAT32 off hand.  If it's important I can look into it in greater
detail.
Comment 5 Jay Turner 1999-11-02 13:07:59 EST
Please send in the a copy of your fstab.  I am betting that the
problem is there and that your root partition is not getting mounted
during the course of the upgrade.
Comment 6 bernard.collins 1999-11-24 10:50:59 EST
I have the same problem when trying to upgrade my laptop from 6.0 to 6.1 using
the pcmcia boot disk and connecting to a local http server. My scsi card is not
plugged in. Here is my /etc/fstab:

/dev/hda1               /                       ext2    noatime        1 1
/dev/hda7               /home                   ext2    noatime        1 2
/dev/hda5               /var                    ext2    noatime        1 2
/dev/hda6               swap                    swap    noatime        0 0
/dev/fd0                /mnt/floppy             ext2    noauto          0 0
/dev/cdrom              /mnt/cdrom              iso9660 noauto,ro,user       0 0
none                    /proc                   proc    defaults        0 0
none                    /dev/pts                devpts  gid=5,mode=620       0 0
/dev/sda4	/mnt/jaz	vfat
user,noatime,exec,dev,suid,rw,noauto,uid=500,gid=500 1 1
Comment 7 bernard.collins 1999-11-24 14:33:59 EST
A followup to my comment above. I worked around the problem by
modifying /etc/fstab. I removed the cdrom and jaz disk lines. I changed the
noatime option to defaults in all lines. I put all the hda devices in numerical
order. I tried each of these changes individually without success. But with all
three changes together, I get past that point in the install.
Comment 8 cxn13 1999-11-27 13:48:59 EST
I get the error when I try to do an FTP install using the pcmcia install disk.
I'm not upgrading my system but doing a full install.
Comment 9 djm 1999-11-28 17:12:59 EST
I am having this problem also but the tricks that worked for Bernard Collins
didn't help me. I think the problem has to do with scsi disks.
My / partition is scsi so I can't take it out
of the fstab like Bernard did with his Jaz.

Here is my trimmed down fstab:

/dev/sda1               /boot                   ext2    defaults        1 2
/dev/sda5               /usr                    ext2    defaults        1 2
/dev/sda9               /                       ext2    defaults        1 1
none                    /proc                   proc    defaults        0 0
none                    /dev/pts                devpts  mode=0622       0 0

I still get the error with this.  By the way, I am asked with partition
contains my boot partition sda6 ot sda9 and I answer sda9.
Comment 10 Jay Turner 1999-11-29 11:06:59 EST
What is on /dev/sda6?  There is a good chance that the installer is ignoring the
selection you are making and, even though you are telling it the installation is
on sda9 it is looking at sda6.
Comment 11 djm 1999-11-29 20:23:59 EST
/dev/sda6 is my /home parition on the same disk.
If the installer looks there it will have a hard time finding .rpm's!
I wonder why it didn't prompt me for the others?
sda6 (home) is a lower number than sda9 (root) is that the cause?
Is there a workaround?
Comment 12 Jay Turner 2000-02-04 13:00:59 EST
There is a known bug in the installer that causes it to ignore the selection or
partition to upgrade, so this is what is affecting you.  This bug is fixed in
Rawhide.

Note You need to log in before you can comment on or make changes to this bug.