Bug 55451 - Kickstart install un-requested language modules
Summary: Kickstart install un-requested language modules
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhl-cg   
(Show other bugs)
Version: 7.2
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tammy Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-31 15:17 UTC by Peter Fales
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-11 15:59:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Fales 2001-10-31 15:17:50 UTC
Description of Problem:

I've been testing kickstart installations of RedHat Linux 7.2.  In my .cfg
file, I have

lang en_US
langsupport --default en_US

However, it seems to go ahead and install all the optional language modules
even
though the instructions in base/comps seem to imply that these should only
be 
loaded if an alternate language is specified.    For example, base/comps
says

  (lang zh_CN): kde-i18n-Chinese

yet the kde-i1n-Chinese package still got loaded

Version-Release number of selected component (if applicable):


How Reproducible:

Very reproducible

Steps to Reproduce:
1.  (See above)

Actual Results:

Language packages all got installed

Expected Results:

Language packages should not be installed

Additional Information:

Comment 1 Peter Fales 2001-10-31 22:40:32 UTC
Hey, I did it one more time with

langsupport --default en_US en_US

Is that the way it's supposed to work?  That gave me the desired results.  Now I
want to go back and try again with 

langsupport --default en_US 

just to make sure I'm not fooling myself


Comment 2 Peter Fales 2001-11-01 22:18:02 UTC
Yes, that did it!  I did it again both with and without the double "en_US" . 
With the 
doubled entry it worked the way I wanted it to, with only one entry the extra
languages
are installed.


Comment 3 Brent Fox 2001-11-02 00:34:13 UTC
So, how do you want to resolve this bug report?  Perhaps we should make the docs
more clear that both entries are needed?

Comment 4 Peter Fales 2001-11-02 04:51:21 UTC
My problem is solved, as long as I'v found a way to work around it, so you
can close it if you want to.

Certainly the documentation could be made clearer.  The current wording is:

langsupport

     Sets the language(s) to install on the system. 

That implies to me that it is possible to install a single language on the 
system, but provides no clue that it is necessary to specify the language twice
in order to install it once!


Comment 5 Brent Fox 2001-11-02 15:00:23 UTC
Actually, I was doing some kickstart installs last night and figued out that you
only need the '--default' if you have more than one language list on the
langsupport line.  

For example:
"langsupport en_US" is perfectly valid.  This will install just the US English
modules and make it the default lang, because that's the only possible one.  So
in your case, you could have just used that.

tfox, can you clarify this behavior in the kickstart docs?  Please ask me if you
need a better description of what the behavior is.

Comment 6 Tammy Fox 2002-02-11 16:45:49 UTC
Thanks for your input. I updated the docs to clarify this matter.
It should appear in the next version of the docs.


Note You need to log in before you can comment on or make changes to this bug.