Bug 554512 - [abrt] crash in istanbul-0.2.2-12.fc12
[abrt] crash in istanbul-0.2.2-12.fc12
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: istanbul (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jef Spaleta
Fedora Extras Quality Assurance
abrt_hash:cb06643db57d83b321849c1a379...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-11 16:06 EST by Zdenek Havlin
Modified: 2010-02-02 08:46 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-02 08:46:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (61.41 KB, text/plain)
2010-01-11 16:06 EST, Zdenek Havlin
no flags Details

  None (edit)
Description Zdenek Havlin 2010-01-11 16:06:19 EST
abrt 1.0.3 detected a crash.

How to reproduce
-----
1. start Istanbul
2. click to record icon in task bar ... end record something
3. click stop icon of istanbul in task bar to end recording

- save dialog appears for while, then application crashes	

Comment: Istanbul crashes after stopping of recording
Attached file: backtrace
cmdline: /usr/bin/python /usr/bin/istanbul
component: istanbul
executable: /usr/bin/python
kernel: 2.6.31.9-174.fc12.x86_64
package: istanbul-0.2.2-12.fc12
rating: 4
reason: Process was terminated by signal 6 (Aborted)
Comment 1 Zdenek Havlin 2010-01-11 16:06:22 EST
Created attachment 383095 [details]
File: backtrace
Comment 2 Paul W. Frields 2010-01-18 10:36:07 EST
Have you tried the new packages in updates-testing?

su -c 'yum --enablerepo=updates-testing update istanbul python-xlib'
Comment 3 Dave Malcolm 2010-01-18 12:32:47 EST
As Paul noted in bug 543278 this looks a lot like a duplicate of that bug: both thread #6 and thread #1 are trying to talk to the X server over the same socket, leading to a garbled "conversation".

However, this looks like it could be a different issue: thread 6 is running a gtk main loop (and trying to display a tooltip), whilst thread 1 is running the main main loop (as it were).
Comment 4 Paul W. Frields 2010-02-02 08:15:43 EST
Reporter, we have pushed a newer istanbul, and I would suggest you try those, and report your results here.  Use the command line shown in comment #2 above.
Comment 5 Zdenek Havlin 2010-02-02 08:46:26 EST
Yep, it seems working now :) no crash, everything went well, video saved successfully.

istanbul 0.2.2-14.fc12

Note You need to log in before you can comment on or make changes to this bug.