Bug 55453 - [sblive] Problem with recording Sound with SBLive on 2.4.9-7smp
[sblive] Problem with recording Sound with SBLive on 2.4.9-7smp
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
: 55471 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-31 11:01 EST by Mike Gahagan
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 16:07:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Gahagan 2001-10-31 11:01:19 EST
Description of Problem:

Sound will not record. I either get silence or noise from resulting wav
files recorded using sox. The stock 2.4.7-10smp kernel works fine. Playback
works fine with either kernel.

Version-Release number of selected component (if applicable):

2.4.9-7

How Reproducible:

Always

Steps to Reproduce:
1. boot from eratta kernel 
2. Start recording
3. 

Actual Results:

resulting output file (in this case a wav) either contains silence or noise.

recording command:
sox -v 2 -t ossdsp -r 44100 -s -w -c 2 /dev/dsp test7.wav


Expected Results:

.wav file containing a useable recording.
Additional Information:
	

Hardware:

Dell Precision 420 w/ SBLive sound card

lspci: (stock 7.2 kernel, eratta output doesn't differ)
[mpg@phoenix callmonitoring]$ /sbin/lspci 
00:00.0 Host bridge: Intel Corporation 82840 840 (Carmel) Chipset Host
Bridge (Hub A) (rev 02)
00:01.0 PCI bridge: Intel Corporation 82840 840 (Carmel) Chipset AGP Bridge
(rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801AA PCI Bridge (rev 02)
00:1f.0 ISA bridge: Intel Corporation 82801AA ISA Bridge (LPC) (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801AA IDE (rev 02)
00:1f.2 USB Controller: Intel Corporation 82801AA USB (rev 02)
00:1f.3 SMBus: Intel Corporation 82801AA SMBus (rev 02)
01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G400 AGP (rev 82)
02:04.0 Ethernet controller: 3Com Corporation 3c905C-TX [Fast Etherlink]
(rev 78)
02:08.0 Multimedia audio controller: Creative Labs SB Live! EMU10000 (rev 07)
02:08.1 Input device controller: Creative Labs SB Live! (rev 07)
02:0e.0 PCI bridge: Digital Equipment Corporation DECchip 21152 (rev 03)

lsmod: (from stock kernel, same modules loaded when using eratta kernel)
[mpg@phoenix callmonitoring]$ /sbin/lsmod 
Module                  Size  Used by
emu10k1                53456   0 (autoclean)
soundcore               4848   4 (autoclean) [emu10k1]
mga                   102880   1
agpgart                28800   3
binfmt_misc             6640   1
autofs                 12096   4 (autoclean)
nfs                    83680   1 (autoclean)
lockd                  53744   1 (autoclean) [nfs]
sunrpc                 70000   1 (autoclean) [nfs lockd]
3c59x                  26944   1
usb-uhci               22880   0 (unused)
usbcore                54528   1 [usb-uhci]
ext3                   67728   6
jbd                    44480   6 [ext3]
Comment 1 Arjan van de Ven 2001-11-21 10:41:08 EST
*** Bug 55471 has been marked as a duplicate of this bug. ***
Comment 2 Alan Cox 2003-06-07 16:07:16 EDT
Should be fixed by current errata, if not please re-open.

Note You need to log in before you can comment on or make changes to this bug.