Bug 554632 - [abrt] crash in Miro-2.5.4-1.fc12
Summary: [abrt] crash in Miro-2.5.4-1.fc12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Miro
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Alex Lancaster
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:7a22918c
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-12 08:06 UTC by Robert Lai
Modified: 2010-09-15 05:51 UTC (History)
6 users (show)

Fixed In Version: Miro-3.0.3-1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-14 05:03:30 UTC


Attachments (Terms of Use)
File: backtrace (404 bytes, text/plain)
2010-01-12 08:06 UTC, Robert Lai
no flags Details
File: cmdline (330 bytes, text/plain)
2010-01-12 08:06 UTC, Robert Lai
no flags Details

Description Robert Lai 2010-01-12 08:06:21 UTC
abrt 1.0.3 detected a crash.

backtrace
-----
Summary: TB7a22918c gst_extractor.py:87:paused_reached:QueryError: query failed

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/miro/plat/renderers/gst_extractor.py", line 87, in paused_reached
    self.duration = self.pipeline.query_duration(gst.FORMAT_TIME)[0]
QueryError: query failed

Local variables in innermost frame:
self: <__main__.Extractor instance at 0xb77a024c>

cmdline: /usr/bin/python /usr/lib/python2.6/site-packages/miro/plat/renderers/gst_extractor.py '/home/robert/Music/\xe5\xa5\xb3\xe6\xad\x8c\xe6\x89\x8b/\xe9\x84\xa7\xe9\xba\x97\xe6\xac\xa3/home/ /home/r /h\xe4\xb8\x80\xe7\x9c\xa8\xe7\x9c\xbc/hom' '/home/robert/.miro/icon-cache/extracted/\xe4\xb8\x80\xe7\x9c\xa8\xe7\x9c\xbc/home/robert/.'
component: Miro
executable: /usr/lib/python2.6/site-packages/miro/plat/renderers/gst_extractor.py
kernel: 2.6.31.9-174.fc12.i686.PAE
package: Miro-2.5.4-1.fc12
uuid: 7a22918c

Comment 1 Robert Lai 2010-01-12 08:06:23 UTC
Created attachment 383198 [details]
File: backtrace

Comment 2 Robert Lai 2010-01-12 08:06:24 UTC
Created attachment 383199 [details]
File: cmdline

Comment 3 Alex Lancaster 2010-01-12 08:24:55 UTC
Is this a duplicate of bug #554631?

Same advice applies here:

"Please describe what you were doing at the time of the crash.   We need to be able to reliably reproduce the error."

Comment 4 will kahn-greene 2010-01-12 15:17:17 UTC
This is probably not a duplicate of bug #554631.  This bug is in the gst_extractor which is the program that runs and pulls out information about the media (duration, thumbnail, ...).

I'm in the process of re-writing the gst_extractor, so I'll harden this section.  This will be for Miro 2.6.

Having said that, I've seen this issue pop up from time to time, it doesn't affect Miro at all, and I've never been able to reliably reproduce the issue.

Comment 5 Alex Lancaster 2010-07-18 08:49:04 UTC
Reporter: can you still reproduce this in the current version of Miro: 3.0.2?  If not, or if I don't hear a response within 1 week, I'll close this bug.  If you can reproduce you're always free to re-open it.

Comment 6 Fedora Update System 2010-08-29 17:18:51 UTC
Miro-3.0.3-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/Miro-3.0.3-1.fc14

Comment 7 Fedora Update System 2010-08-29 17:25:58 UTC
Miro-3.0.3-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/Miro-3.0.3-1.fc13

Comment 8 Fedora Update System 2010-08-29 17:30:03 UTC
Miro-3.0.3-1.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/Miro-3.0.3-1.fc12

Comment 9 Fedora Update System 2010-08-30 19:40:35 UTC
Miro-3.0.3-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update Miro'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/Miro-3.0.3-1.fc14

Comment 10 Fedora Update System 2010-09-14 05:01:27 UTC
Miro-3.0.3-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2010-09-15 05:33:25 UTC
Miro-3.0.3-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2010-09-15 05:48:34 UTC
Miro-3.0.3-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.