Bug 55464 - ghostscript package has unnecessary dependency on ttfonts-ja
ghostscript package has unnecessary dependency on ttfonts-ja
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ghostscript (Show other bugs)
7.2
All Linux
medium Severity low
: ---
: ---
Assigned To: Crutcher Dunnavant
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-31 13:46 EST by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-01 11:46:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-10-31 13:46:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (WinNT; U)

Description of problem:
I tried to upgrade to the ghostscript package contained in RHL 7.2 and got a dependency error: "ttfonts-ja is needed by ghostscript-6.51-12".  Why should I 
have to install Japenese fonts when I don't even speak or read Japenese?  This dependency needs to be broken out of the main ghostscript package into a 
seperate ghostscript-intl or ghostscript-ja package.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Make sure the ttfonts-ja package is not installed.
2. Try to install ghostscript-6.51 package.
3.
	

Additional info:
Comment 1 Jean Berthomieu 2001-11-01 06:40:39 EST
Now there is a Japanese version of RH7.2, and I'm wondering why there are still
so many oriental fonts and tools unavoidable (as long as we only use their
English counterpart) in the occidental version?
Comment 2 Bill Nottingham 2001-11-01 11:46:19 EST
There is no separate japanese 7.2.
Comment 3 Crutcher Dunnavant 2001-11-01 17:59:18 EST
because ghostscript is linked against japanese character libs, and expects to
have those fonts. Not a bug.
Comment 4 Dan Anderson 2001-11-03 12:04:33 EST
ghostscript has excessive requirements, requiring 20MB of files.
These are not needed if you don't have a printer and don't use
Japanese fonts (as in a remote server without X).

I only need ghostscript for the ps2pdf and the pdf2ps utilities.

-rw-r--r--    1 root     root     11330381 Nov  2 23:02 Omni-0.5.0-4.i386.rpm

-rw-r--r--    1 root     root      8777148 Sep  7 ttfonts-ja-1.0-6.noarch.rpm
Comment 5 Crutcher Dunnavant 2001-11-06 22:22:59 EST
Sorry. I cannot restrict the functionality of ghostscript based upon what a few
people need. For better or worse, it is our postscript interpreter, and this
means it must support everything we want to do with postscript.
Comment 6 Alexei Podtelezhnikov 2001-12-20 03:35:14 EST
On the other hand, an example for you is xfs, Red Hat's X font server. How come 
it doesn't require all unicode fonts installed when ghostscript does? There is 
a broken logic here. Don't you see? ttfonts-ja should be optional just like all 
the xfonts. I'm sure all the installation scripts could be moved to ttfonts-ja 
from ghostscript if any. We talking 14 Megs here. The whole koffice takes less 
space.

On a side note, i just "rpm -e --nodeps ttfonts-ja" outta here because they 
where screwing my cyrillic support here by unkindly providing ugly cp1251-
encoded fonts. :(

Note You need to log in before you can comment on or make changes to this bug.