Bug 55483 - rndc does not work after default installation
Summary: rndc does not work after default installation
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bind   
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-01 01:39 UTC by Russell Stuart
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-01 01:39:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Russell Stuart 2001-11-01 01:39:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.12-0.1custom i686)

Description of problem:
After a default installation running "rndc stop" to flush the name server's
journals and then stop it gives an error message.  The reason is confusion
over the name of the key used by rndc.  In /etc/rndc.conf it is called
"key" in some places and "rndckey" in others.  The same thing happens in
/etc/named.conf

Version-Release number of selected component (if applicable):
bind-9.1.3-4
caching-nameserver-7.2-1

How reproducible:
Always

Steps to Reproduce:
1. Do a default installation of bind.rpm and caching-nameserver.rpm
2. Run /etc/rc.d/init.d/named start
3. Run rndc stop

Actual Results:  rndc: get key definition: not found 

Expected Results:  rndc: stop command successful

Work around: change all the key references in /etc/named.conf and
/etc/rndc.conf to "rndckey".

Comment 1 Bernhard Rosenkraenzer 2001-11-05 14:28:13 UTC
Fixed in 9.2.0-0.rc8.2 



Note You need to log in before you can comment on or make changes to this bug.