Bug 554876 - [abrt] crash in hunspell-1.2.8-13.fc12
Summary: [abrt] crash in hunspell-1.2.8-13.fc12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hunspell
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:73054e2d83c4b4db21d805ce304...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-12 21:26 UTC by Christopher Beland
Modified: 2010-01-19 19:32 UTC (History)
1 user (show)

Fixed In Version: 1.2.8-14.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-19 19:32:56 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (28.31 KB, text/plain)
2010-01-12 21:26 UTC, Christopher Beland
no flags Details
hunspell -a -d en_GB workfile (37.92 KB, text/plain)
2010-01-18 09:27 UTC, Caolan McNamara
no flags Details

Description Christopher Beland 2010-01-12 21:26:02 UTC
abrt 1.0.3 detected a crash.

How to reproduce: This is the result of dumping most of the contents of http://en.wikipedia.org/wiki/7_July_2005_London_bombings into a pipe to hunspell from a Python script, after encode('UTF-8').
Attached file: backtrace
cmdline: hunspell -a -d en_GB
component: hunspell
executable: /usr/bin/hunspell
kernel: 2.6.31.9-174.fc12.i686
package: hunspell-1.2.8-13.fc12
rating: 4
reason: Process was terminated by signal 6 (Aborted)

Comment 1 Christopher Beland 2010-01-12 21:26:04 UTC
Created attachment 383339 [details]
File: backtrace

Comment 2 Caolan McNamara 2010-01-13 09:10:08 UTC
I can see where this happens, and can probably fix it in the immediate place, but I can't reproduce it from scratch. 

Can I get the python script to reproduce this ?

Comment 3 Caolan McNamara 2010-01-18 09:27:36 UTC
Created attachment 385032 [details]
hunspell -a -d en_GB workfile

extracted crasher text

Comment 4 Caolan McNamara 2010-01-18 09:42:07 UTC
Fix checked in and logged upstream, fix will be in >= 1.2.8-14.f12

Comment 5 Fedora Update System 2010-01-18 09:49:21 UTC
hunspell-1.2.8-14.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/hunspell-1.2.8-14.fc12

Comment 6 Fedora Update System 2010-01-19 01:00:58 UTC
hunspell-1.2.8-14.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hunspell'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0735

Comment 7 Fedora Update System 2010-01-19 19:32:51 UTC
hunspell-1.2.8-14.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.