Bug 554978 - Can't login to ICQ or AIM servers "Received unexpected response from http://api.oscar.aol.com/aim/startOSCARSession"
Summary: Can't login to ICQ or AIM servers "Received unexpected response from http://a...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: pidgin
Version: 12
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Warren Togami
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 554923
TreeView+ depends on / blocked
 
Reported: 2010-01-13 09:59 UTC by Lev Shamardin
Modified: 2010-02-11 03:24 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-17 12:09:16 UTC
Type: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 506647 None None None Never

Description Lev Shamardin 2010-01-13 09:59:15 UTC
Description of problem:
Today I was not able to login to ICQ using pidgin. I've got the message
"Received unexpected response from http://api.oscar.aol.com/aim/startOSCARSession" instead.

Version-Release number of selected component (if applicable):
pidgin-2.6.5-1.fc12.i686
libpurple-2.6.5-1.fc12.i686

How reproducible:
Always.

Steps to Reproduce:
1. Install pidgin
2. Setup an icq account with default options.
3. Try to login
  
Actual results:
"Received unexpected response from http://api.oscar.aol.com/aim/startOSCARSession"

Expected results:
Normal work

Additional info:
The problem can be 'fixed' by disabling 'use clientLogin' in the advanced settings tab.

Comment 1 Chris Gline 2010-01-13 17:30:47 UTC
I am able to replicate this same error message in Windows 7 x64 using Pidgin 2.6.4.

I am trying to sign-in to a AIM account.  Figured I'd append it to this ticket, it may be a AOL issue causing this error, and not a bug.

Comment 2 Warren Togami 2010-01-13 22:35:10 UTC
There will be a package update that forces this option... but only after upstream decides what to do about this.

Comment 3 Christopher Beland 2010-01-14 15:04:56 UTC
Similar problems in Empathy after update to libpurple-2.6.5-1 (Bug 554923 for AIM, possibly Bug 555297 for ICQ), but the noted workaround cannot be applied.

Comment 4 Stu Tomlinson 2010-01-17 12:09:16 UTC
I believe AOL have fixed their servers.


Note You need to log in before you can comment on or make changes to this bug.