Bug 55509 - Generated grub.conf entry is incorrect for windows 95 installed on /dev/hdb1
Generated grub.conf entry is incorrect for windows 95 installed on /dev/hdb1
Status: CLOSED DUPLICATE of bug 23643
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-01 10:07 EST by John
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-02 15:20:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John 2001-11-01 10:07:12 EST
Description of Problem:

If windows 95 is located on /dev/hdb1 when Redhat 7.2 is installed, the   
entry in /boot/grub/grub.conf to boot that os is incorrect.  Win95 does not
boot when the dos entry in grub is chosen at boot.


Version-Release number of selected component (if applicable):


How Reproducible:

Always.

Steps to Reproduce:

1. Install Win95 on /dev/hdb1
2. Install Redhat 7.2 on /dev/hda (or wherever, I guess.)
3. Reboot, and select the "dos" entry in the grub menu.  Windows won't boot.

Actual Results:


Expected Results:


Additional Information:

As much as I hate to fix things to make Windows work, :) here's the way I
updated my grub.conf.  The dos entry is now:

title DOS
        map (hd0) (hd1)
        map (hd1) (hd0)
        rootnoverify (hd1,0)
        makeactive
        chainloader +1
        boot

I think this is the correct fix.
Comment 1 Jeremy Katz 2001-11-02 15:20:51 EST
Yes, anaconda doesn't currently handle the writing out of any additional drive
mapping information at present.  It is being considered for the next release as
a part of a rework of all of the bootloader configuration present in anaconda
Comment 2 Jeremy Katz 2002-01-21 20:27:01 EST
grub instead of lilo, but same bug

*** This bug has been marked as a duplicate of 23643 ***

Note You need to log in before you can comment on or make changes to this bug.