Bug 555147 - SIGABRT due to "BadDrawable (invalid Pixmap or Window parameter)" XError running /usr/share/ibus/ui/gtk/main.py
SIGABRT due to "BadDrawable (invalid Pixmap or Window parameter)" XError runn...
Status: CLOSED DUPLICATE of bug 538789
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
abrt_hash:34dcd360b01d5e6438aad055cca...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-13 14:39 EST by ratal
Modified: 2010-01-14 15:03 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-13 21:15:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (27.64 KB, text/plain)
2010-01-13 14:40 EST, ratal
no flags Details

  None (edit)
Description ratal 2010-01-13 14:39:51 EST
abrt 1.0.3 detected a crash.

How to reproduce
-----
1. Launnch application using python
2.
3.

Comment: Applications are crashing in my PC ( ibus, elisa, configuration tools, games like WorldOfGoo)
Attached file: backtrace
cmdline: python /usr/share/ibus/ui/gtk/main.py
component: python
executable: /usr/bin/python
kernel: 2.6.31.9-174.fc12.i686.PAE
package: python-2.6.2-2.fc12
rating: 4
reason: Process was terminated by signal 6 (Aborted)
Comment 1 ratal 2010-01-13 14:40:02 EST
Created attachment 383547 [details]
File: backtrace
Comment 2 Dave Malcolm 2010-01-13 19:14:50 EST
Thank you for reporting this bug.

How reproducible is this problem?  If you run the program from a terminal, is an error message printed?

What is the output of running the following command?
  rpm -q ibus

Looking at the backtrace, it looks like an XError happened in frame 7 of the program's single thread inside "process_responses": 
  "BadDrawable (invalid Pixmap or Window parameter)"

Reassigning component from "python" to "ibus";  hopefully the ibus maintainer will be able to figure this out further or reassign as necessary.
Comment 3 Peng Huang 2010-01-13 21:15:50 EST
I think it is the same problem with bug #538789

*** This bug has been marked as a duplicate of bug 538789 ***
Comment 4 ratal 2010-01-14 15:03:34 EST
This is reproduceable from  terminal launch for WorldOfGoo, Elisa and system-config-samba .
From WorlOfGoo, terminal output is :
/usr/bin/WorldOfGoo: line 30: 15272 Erreur de segmentation 

For system-config-samba (maybe not ibus, not sure):
Traceback (most recent call last):
  File "/usr/bin/system-config-samba", line 53, in <module>
    mainWindow.MainWindow (debug_flag = debug_flag, use_dbus = use_dbus)
  File "/usr/share/system-config-samba/mainWindow.py", line 97, in __init__
    self.samba_data = sambaConfig.SambaConfig (self.samba_backend)
  File "/usr/lib/python2.6/site-packages/scsamba/core/sambaConfig.py", line 29, in __init__
    self.parseFile ()
  File "/usr/lib/python2.6/site-packages/scsamba/core/sambaConfig.py", line 32, in parseFile
    return self.parse (self.backend.readSmbConf ())
  File "/usr/lib/python2.6/site-packages/scsamba/dbus/proxy/sambaBackend.py", line 48, in readSmbConf
    return self.dbus_interface.readSmbConf ()
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.fedoraproject.slip.dbus.service.PolKit.NotAuthorizedException.org.fedoraproject.config.samba.configure: 

From Elisa, it is a bit tricky as I have just a black screen, but not really a proper crash :
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/twisted/internet/defer.py", line 630, in gotResult
    _deferGenerator(g, deferred)
  File "/usr/lib/python2.6/site-packages/twisted/internet/defer.py", line 607, in _deferGenerator
    deferred.callback(result)
  File "/usr/lib/python2.6/site-packages/twisted/internet/defer.py", line 243, in callback
    self._startRunCallbacks(result)
  File "/usr/lib/python2.6/site-packages/twisted/internet/defer.py", line 312, in _startRunCallbacks
    self._runCallbacks()
--- <exception caught here> ---
  File "/usr/lib/python2.6/site-packages/twisted/internet/defer.py", line 328, in _runCallbacks
    self.result = callback(self.result, *args, **kw)
  File "/usr/lib/python2.6/site-packages/elisa/plugins/flickr/resource_provider.py", line 269, in response_read
    raise ValueError('%s: %s' %(err_code, err_msg))
exceptions.ValueError: 108: Invalid frob

Output of rpm -q ibus is :
ibus-1.2.0.20091204-2.fc12.i686

Note You need to log in before you can comment on or make changes to this bug.