Bug 555181 - [abrt] crash in wallpapoz-0.4.1-11.svn92_trunk.fc12
Summary: [abrt] crash in wallpapoz-0.4.1-11.svn92_trunk.fc12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wallpapoz
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Mamoru TASAKA
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:01f41b3c
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-13 22:33 UTC by Ferran Eloi Gutiérrez Martos
Modified: 2010-02-18 22:30 UTC (History)
1 user (show)

Fixed In Version: wallpapoz-0.4.1-15.svn92_trunk.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-18 22:20:05 UTC


Attachments (Terms of Use)
File: backtrace (546 bytes, text/plain)
2010-01-13 22:33 UTC, Ferran Eloi Gutiérrez Martos
no flags Details

Description Ferran Eloi Gutiérrez Martos 2010-01-13 22:33:35 UTC
abrt 1.0.3 detected a crash.

backtrace
-----
Summary: TB01f41b3c wallpapoz:221:get_selected_iter_of_treeview:IndexError: list index out of range

Traceback (most recent call last):
  File "/usr/bin/wallpapoz", line 361, in add_wallpapers_files
    iter = self.get_selected_iter_of_treeview("wallpaper")
  File "/usr/bin/wallpapoz", line 221, in get_selected_iter_of_treeview
    holdparent = pathlist[0][0]
IndexError: list index out of range

Local variables in innermost frame:
type_selection: wallpaper
self: <__main__.Wallpapoz instance at 0x1692560>
pathlist: []
length_of_path_list: 0

cmdline: python /usr/bin/wallpapoz
component: wallpapoz
executable: /usr/bin/wallpapoz
kernel: 2.6.31.9-174.fc12.x86_64
package: wallpapoz-0.4.1-11.svn92_trunk.fc12
uuid: 01f41b3c

Comment 1 Ferran Eloi Gutiérrez Martos 2010-01-13 22:33:38 UTC
Created attachment 383566 [details]
File: backtrace

Comment 2 Mamoru TASAKA 2010-01-18 14:25:32 UTC
Please give me the following information
- the detailed procedure to reproduce this issue
- the file ~/.wallpapoz itself
- the number of workspaces
- desktop environment you are using
- whether you have some desktop effects enabled or not

Comment 3 Mamoru TASAKA 2010-02-07 19:46:17 UTC
Well, still I cannot reproduce this issue, however I just
guessed what happened here and applied a possible workaround.

Comment 4 Fedora Update System 2010-02-07 19:59:25 UTC
wallpapoz-0.4.1-14.svn92_trunk.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/wallpapoz-0.4.1-14.svn92_trunk.fc12

Comment 5 Fedora Update System 2010-02-07 20:00:31 UTC
wallpapoz-0.4.1-14.svn92_trunk.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/wallpapoz-0.4.1-14.svn92_trunk.fc11

Comment 6 Fedora Update System 2010-02-08 18:56:57 UTC
wallpapoz-0.4.1-15.svn92_trunk.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/wallpapoz-0.4.1-15.svn92_trunk.fc12

Comment 7 Fedora Update System 2010-02-08 18:58:32 UTC
wallpapoz-0.4.1-15.svn92_trunk.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/wallpapoz-0.4.1-15.svn92_trunk.fc11

Comment 8 Fedora Update System 2010-02-09 21:01:24 UTC
wallpapoz-0.4.1-15.svn92_trunk.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wallpapoz'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1687

Comment 9 Fedora Update System 2010-02-18 22:19:26 UTC
wallpapoz-0.4.1-15.svn92_trunk.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2010-02-18 22:30:03 UTC
wallpapoz-0.4.1-15.svn92_trunk.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.