Bug 555219 - [abrt] crash in java-1.6.0-openjdk-1:1.6.0.0-33.b16.fc12
[abrt] crash in java-1.6.0-openjdk-1:1.6.0.0-33.b16.fc12
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rxtx (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Levente Farkas
Fedora Extras Quality Assurance
abrt_hash:e92459064a61620a963f60c51b6...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-13 21:23 EST by Ed Marshall
Modified: 2010-03-27 11:01 EDT (History)
8 users (show)

See Also:
Fixed In Version: rxtx-2.2-0.1.20100211.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-08 22:13:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (46.69 KB, text/plain)
2010-01-13 21:23 EST, Ed Marshall
no flags Details
JVM error report (59.18 KB, text/plain)
2010-01-13 21:27 EST, Ed Marshall
no flags Details
Sun JVM error log (44.76 KB, text/plain)
2010-01-14 20:52 EST, Ed Marshall
no flags Details

  None (edit)
Description Ed Marshall 2010-01-13 21:23:55 EST
abrt 1.0.3 detected a crash.

How to reproduce
-----
1. Attach an Arduino Duemilanove (http://arduino.cc/) via USB.
2. Install Arduino IDE software (http://code.google.com/p/arduino/ or http://arduino.cc/en/Main/Software)
3. Follow Button State Change Detection example (http://arduino.cc/en/Tutorial/ButtonStateChange), configuring Arduino appropriately and compiling/uploading example sketch.
4. Open serial monitor window to see serial output from Arduino. (Uses RXTX at 9600bps 8N1; Arduino USB interface is FTDI.)
5. Upon pressing button (and thus generating serial output from the Arduino), JVM crashes.


Attached file: backtrace
cmdline: java -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel processing.app.Base
component: java-1.6.0-openjdk
executable: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/java
kernel: 2.6.31.6-162.fc12.x86_64
package: java-1.6.0-openjdk-1:1.6.0.0-33.b16.fc12
rating: 3
reason: Process was terminated by signal 6 (Aborted)
Comment 1 Ed Marshall 2010-01-13 21:23:57 EST
Created attachment 383592 [details]
File: backtrace
Comment 2 Ed Marshall 2010-01-13 21:27:53 EST
Created attachment 383594 [details]
JVM error report

The following message was output when the JVM crashed, and I'm attaching the referenced error report file.

#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007f56b0eb866d, pid=10920, tid=140010304169744
#
# JRE version: 6.0-b16
# Java VM: OpenJDK 64-Bit Server VM (14.0-b16 mixed mode linux-amd64 )
# Distribution: Custom build (Thu Nov 12 09:47:56 EST 2009)
# Problematic frame:
# C  [librxtxSerial-2.1-7.so+0x866d]  read_byte_array+0x3d
#
# An error report file with more information is saved as:
# /home/esm/ard/arduino-0017/hs_err_pid10920.log
#
# If you would like to submit a bug report, please include
# instructions how to reproduce the bug and visit:
#   http://icedtea.classpath.org/bugzilla
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
./arduino: line 20: 10920 Aborted                 (core dumped) java -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel processing.app.Base
Comment 3 Mark Wielaard 2010-01-14 08:10:58 EST
This looks like a bug in librxtxSerial-2.1-7.so, could you look in the report file: /home/esm/ard/arduino-0017/hs_err_pid10920.log to see where it is installed? The bug should probably be reassigned to the package that provides rxtx.
Comment 4 Ed Marshall 2010-01-14 10:08:53 EST
That log is actually my second attachment above: "JVM error report". :)

I'm guessing this is the path you're curious about?

    /usr/lib64/rxtx/librxtxSerial-2.1-7.so

(It's from the Fedora package "rxtx".)

Interestingly, while I haven't personally tested this yet, folks are reporting that the Fedora build of rxtx, when coupled with the Sun JVM, seems to work properly, which suggests that this might actually be a problem with OpenJDK, or at least a point of differentiation between OpenJDK and Sun's release.

I'll try and get a moment to test that personally tonight or tomorrow.
Comment 5 Ed Marshall 2010-01-14 20:52:02 EST
Created attachment 384501 [details]
Sun JVM error log

I stand corrected; Sun's JVM produced the same results, so you're right, it's probably a good idea to reassign to rxtx. Here's the JVM I just tried it on, as downloaded from Sun's website, for reference:

java version "1.6.0_18"
Java(TM) SE Runtime Environment (build 1.6.0_18-b07)
Java HotSpot(TM) 64-Bit Server VM (build 16.0-b13, mixed mode)

I've attached the error log to this message, for comparison.
Comment 6 Fedora Update System 2010-02-11 12:28:53 EST
rxtx-2.2-0.1.20100211.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/rxtx-2.2-0.1.20100211.fc12
Comment 7 Ed Marshall 2010-02-12 18:14:26 EST
Yep, that fixes it!

I'd also noticed a similar problem connecting to XBees via RXTX, which I assumed was the same issue, and it was; they're now working just fine via the java xbee-api.

Thanks!
Comment 8 Fedora Update System 2010-02-12 19:42:30 EST
rxtx-2.2-0.1.20100211.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rxtx'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1841
Comment 9 Fedora Update System 2010-03-08 22:13:34 EST
rxtx-2.2-0.1.20100211.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.