Bug 555281 - Got some harmless errors when checking virtio qcow2 image after running kvm autotest 'ioquit'
Got some harmless errors when checking virtio qcow2 image after running kvm a...
Status: CLOSED DUPLICATE of bug 606651
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.4.z
All Linux
medium Severity medium
: rc
: ---
Assigned To: Kevin Wolf
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2010-01-14 04:45 EST by Yolkfull Chow
Modified: 2010-11-09 07:51 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-15 07:54:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Yolkfull Chow 2010-01-14 04:45:01 EST
Description of problem:
Run kvm autotest 'ioquit' with virtio + qcow2 format image, will failed during checking image got some errors like this:

ERROR cluster 1617900 refcount=1 reference=0


Sometimes can find many such kind of errors though image is not corrupted. 
Confirmed with Kevin, these errors are harmless besides wasting some disk space for guest.


Version-Release number of selected component (if applicable):
kvm-83-105.el5_4.18

How reproducible:
So often

Steps to Reproduce:
1. run autotest kvm subtest 'ioquit'
(This test mainly runs dbench within guest and during dbench is running in guest, kill the autotest process along with all its child-processes including 'qemu-kvm'.
2. 
3.
  
Actual results:
Got some errors though they are harmless

Expected results:
Should not got these harmless errors if image is actually not corrupted.
Maybe let qemu-img fix this or replace 'Error' with 'Warning' as Kevin referred.

Additional info:
Comment 2 Kevin Wolf 2010-07-15 07:54:43 EDT

*** This bug has been marked as a duplicate of bug 606651 ***

Note You need to log in before you can comment on or make changes to this bug.