Bug 555284 - test for unexpanded macros in srpms
test for unexpanded macros in srpms
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-14 04:56 EST by Kamil Páral
Modified: 2010-02-19 19:09 EST (History)
4 users (show)

See Also:
Fixed In Version: rpmlint-0.94-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-25 18:19:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2010-01-14 04:56:37 EST
Koji builds the SRPM in a fairly empty environment. Not all rpm macro definitions may be available at that time. The built SRPM should not contain unexpanded macros in any text field like %description.

----
We have received this ticket as a part of our comparative testing tool - rpmguard:
https://fedorahosted.org/autoqa/ticket/108
We believe this is more likely concern of rpmlint so we redirect the request here.
Comment 1 Ville Skyttä 2010-01-14 12:25:03 EST
rpmlint should already do that for summary, description, group, buildhost, license, and changelog.  Do you have an reproducer where it doesn't?  I suppose more tags could be added to the list of checked ones though.

$ rpm -qp --qf="%{DESCRIPTION}\n" foo-1.0-1.fc11.src.rpm
Foo %foo bar

$ rpmlint foo-1.0-1.fc11.src.rpm
foo.src: W: macro-in-%description %foo

$ rpmlint -I macro-in-%description
macro-in-%description:
This tag contains something that looks like an unexpanded macro; this is often
the sign of a misspelling. Please check your specfile.
Comment 2 Kamil Páral 2010-01-15 03:50:34 EST
Adding Adam Jackson to needinfo as he is the reporter of the original bug.
Comment 3 Ville Skyttä 2010-01-19 17:09:18 EST
Upstream rpmlint svn now checks for unexpanded macros in a lot more tags, this will most likely be in rpmlint 0.93 once released.
http://rpmlint.zarb.org/cgi-bin/trac.cgi/changeset/1697
Comment 4 Ville Skyttä 2010-01-25 18:19:56 EST
Closing as rawhide (0.93-2 will hopefully appear in the next push), feel free to reopen or submit another bug if some tags for which this would be beneficial got left out.
Comment 5 Fedora Update System 2010-01-25 18:28:51 EST
rpmlint-0.93-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/rpmlint-0.93-2.fc12
Comment 6 Fedora Update System 2010-01-31 18:23:14 EST
rpmlint-0.94-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/rpmlint-0.94-1.fc12
Comment 7 Fedora Update System 2010-02-19 19:09:41 EST
rpmlint-0.94-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.