Bug 555296 - Admin server not starting under Solaris with default config
Summary: Admin server not starting under Solaris with default config
Keywords:
Status: CLOSED DUPLICATE of bug 618454
Alias: None
Product: 389
Classification: Retired
Component: Admin
Version: 1.2.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Rich Megginson
QA Contact: Chandrasekar Kannan
URL:
Whiteboard:
Depends On:
Blocks: 389_1.2.7
TreeView+ depends on / blocked
 
Reported: 2010-01-14 10:59 UTC by Steffen Blume
Modified: 2015-01-04 23:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-20 20:54:32 UTC


Attachments (Terms of Use)

Description Steffen Blume 2010-01-14 10:59:29 UTC
Description of problem:
SSL_ClearSessionCache() is called in mod_admserv_unload without checking, if nss was initialized. Admin server cannot start with disabled NSSEngine in default/generated console.conf. Error msg from nss in log.

Version-Release number of selected component (if applicable):
1.1.9

How reproducible:


Steps to Reproduce:
1. Set NSSEngine to off in console.conf
2. start admin server
  
Actual results:
admin server not starting. nss error in log: Assertion failure: SECSuccess == rv, at sslnonce.c:156

Expected results:
Starting admin server without ssl.

Additional info:
389 ds and needed libraries were compiled on OpenSolaris (SunOS 5.11) using gcc with sun as for 32 bit.

Comment 1 Rich Megginson 2010-10-01 20:27:42 UTC
This may be the same as https://bugzilla.redhat.com/show_bug.cgi?id=618454

Comment 3 Rich Megginson 2010-10-20 20:54:32 UTC

*** This bug has been marked as a duplicate of bug 618454 ***


Note You need to log in before you can comment on or make changes to this bug.