Bug 55535 - daemon() function should change CWD before starting
Summary: daemon() function should change CWD before starting
Status: CLOSED DUPLICATE of bug 53304
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-01 18:37 UTC by Joshua Jensen
Modified: 2014-03-17 02:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-01 18:37:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joshua Jensen 2001-11-01 18:37:20 UTC
[root@joshua root]# umount /mnt/floppy/
[root@joshua root]# mount /mnt/floppy/
[root@joshua root]# cd /mnt/floppy/

[root@joshua floppy]# service smb restart
Shutting down SMB services:                                [  OK  ]
Shutting down NMB services:                                [  OK  ]
Starting SMB services:                                     [  OK  ]
Starting NMB services:                                     [  OK  ]

[root@joshua floppy]# cd
[root@joshua root]# umount /mnt/floppy/
umount: /mnt/floppy: device is busy
[root@joshua root]# fuser -vm /mnt/floppy/

                     USER        PID ACCESS COMMAND
/mnt/floppy/         root       7252 ..c..  smbd
                     root       7257 ..c..  nmbd


Why is this?  smbd and nmbd do need a cwd... but does it have to be
/mnt/floppy?  Why not have the daemon() function of
/etc/rc.d/init.d/functions start process in / if not explicitly specified
otherwise?

Joshua Jensen

Comment 1 Bill Nottingham 2002-01-25 06:19:31 UTC

*** This bug has been marked as a duplicate of 53304 ***


Note You need to log in before you can comment on or make changes to this bug.