This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 555496 - FTBFS perl-DBI-Dumper-2.01-8.fc12
FTBFS perl-DBI-Dumper-2.01-8.fc12
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-DBI-Dumper (Show other bugs)
13
All Linux
high Severity high
: ---
: ---
Assigned To: Iain Arnell
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On: 557015 614980
Blocks: F13FTBFS
  Show dependency treegraph
 
Reported: 2010-01-14 12:34 EST by FTBFS
Modified: 2010-07-25 04:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-25 04:17:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (56.38 KB, text/plain)
2010-01-14 12:34 EST, FTBFS
no flags Details
build.log (9.55 KB, text/plain)
2010-01-14 12:34 EST, FTBFS
no flags Details
mock.log (980 bytes, text/plain)
2010-01-14 12:34 EST, FTBFS
no flags Details
root.log (65.15 KB, text/plain)
2010-01-14 12:34 EST, FTBFS
no flags Details
build.log (9.64 KB, text/plain)
2010-01-14 12:34 EST, FTBFS
no flags Details
mock.log (988 bytes, text/plain)
2010-01-14 12:34 EST, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-01-14 12:34:19 EST
perl-DBI-Dumper-2.01-8.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-01-14 12:34:22 EST
Created attachment 384246 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-01-14 12:34:23 EST
Created attachment 384247 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-01-14 12:34:24 EST
Created attachment 384248 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-01-14 12:34:26 EST
Created attachment 384249 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-01-14 12:34:27 EST
Created attachment 384250 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-01-14 12:34:28 EST
Created attachment 384251 [details]
mock.log

mock.log for x86_64
Comment 7 Marcela Mašláňová 2010-02-05 07:14:41 EST
I wonder if this problem with C.so could be caused by our patch of perl core package. We removed rpath which could lead to problems with linking (maybe). See in perl/devel perl-USE_MM_LD_RUN_PATH.patch
Comment 8 Bug Zapper 2010-03-15 09:58:41 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Ralf Corsepius 2010-06-29 19:03:47 EDT
I would propose this package to be retired.

Upstream appears dead, the CPAN build matrix looks frightening.
Also, AFAICT this package is not used by any package in Fedora.
Comment 10 Iain Arnell 2010-07-25 04:17:34 EDT
This seems to be due to EU::MM changes detailed in bug #557015. As it's not using Module::Install, using DESTDIR doesn't help, but I've simply added an rm -rf to the spec to clean up the confused installation (and modernized the spec while I was at it).

http://koji.fedoraproject.org/koji/buildinfo?buildID=186350

Note You need to log in before you can comment on or make changes to this bug.