Bug 55555 - Because Redhat has renamed menu.lst to grub.conf menu does not work from FAT partition
Because Redhat has renamed menu.lst to grub.conf menu does not work from FAT ...
Status: CLOSED DUPLICATE of bug 107748
Product: Red Hat Linux
Classification: Retired
Component: grub (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-01 16:49 EST by Hardy Mayer
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-11 16:48:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hardy Mayer 2001-11-01 16:49:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5+) Gecko/20011031

Description of problem:
I upgaded from previous versions of RH so I have the /boot directory on a
scsi partition (hd1,8), whereas my Windows 2000 ntldr resides 
on (hd0.0).  I installed grub on (hd0) and everythjing boots fine, except
the menu is unavailable, sine RedHat chose to change stage2 so that the
name of the configfile is grub.conf (which gets truncated to grub.con on
the FAT fs), rather than leave the name menu.lst  alone. 

In order to get the boot menu, I have to manually specify:
grub> configfile (hd0,0)/grub/grub.con

I presume I am not the only one with this kind of setup, so it
would make sense to replace the standard name grub.conf with
the original menu.lst (or grub.cfg) in future releases. 

I understand the "philosophy" (since 7.2 installs  a small /boot partition
on the first disk, but in cases like mine with mixe scsi and
ide disks.  It does not work. 

Booting from scsi works for Linux, but not for W2k

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Machine with ide and scsi disk -- W2K on ide-disk, linux on scsi
2. put the /grub or /boot/grub directory on the first partition of ide-disk
3. install grub from floppy by setting:
grub> rootnoverify (hd0,0)
grub> setup (hd0)

In order to get menu need to load manually as above

Actual Results: 

Expected Results:   stage2 should have looked for a file menu.lst in
(hd0,0)/grub.
The RedHat-hacked stage2 looks instead for grub.conf, and does not find it. 

Additional info:

I managed to fix the problem by downloading grub-0.90 from alpha.gnu.org,
recompiling it and installing the original stage2. 

I will try to see if using the small /boot partition on ther ide-disk which
was created by RH-7.1 but never used can also fix this problem. 

I also suspect that I will need to remap the scsi and ide drives in order
to get dual-booting from scsi to work. 
FYI  Here is my device.map
(fd0)
/dev/floppy/0
(hd0)
/dev/ide/host0/bus0/target0/lun0/disc
(hd1)
/dev/scsi/host0/bus0/target0/lun0/disc
(hd2)
/dev/scsi/host0/bus0/target1/lun0/disc
(hd3)
/dev/scsi/host0/bus0/target4/lun0/disc
Comment 1 Jeremy Katz 2001-11-01 17:10:09 EST
Actually, the solution is going to have a fallback config file name... just
didn't have time to do that once this came up.

Also, are you certain that the grub.conf can't be loaded from the /boot on your
SCSI device?
Comment 2 Hardy Mayer 2001-11-01 17:48:36 EST
In the meantime I installed grub on the little ext2 boot partition on the IDE
disk, and everything works fine, even the Redhat spashimage. 

I presume I could have pointed the setup to (hd1,9), the scsi partition where 
my linux system lives. 

What I meant with my comment above, was that if change my BIOS to use the scsi
disk as the boot device (which I did until now under LILO), linux wil boot fine,
but wwen I try to boot W2K (not needed very often -- except at tx-time :))grub
complains that it cant load ntldr although the file is there. 
I suspect I need to do a remapping (hd0) <-> (hd1) for this to work, but
for the moment I am happy that the dual-boot works, and I have the BIOS-change
to scsi as a fallback (I am even leaving lilo unchanged there for a while). 

Regards, 
Hardy Mayer
Comment 3 Joe Krahn 2001-11-14 00:07:39 EST
From original post:
>Booting from scsi works for Linux, but not for W2k

We boot Win2K from SCSI disk at work. So, it does work,
but I suppose it could depend on your specific hardware.

Joe Krahn
Comment 4 Peter Jones 2005-01-11 16:48:31 EST

*** This bug has been marked as a duplicate of 107748 ***

Note You need to log in before you can comment on or make changes to this bug.