Bug 555590 - [abrt] crash in Miro-2.5.4-1.fc12
Summary: [abrt] crash in Miro-2.5.4-1.fc12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Miro
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Alex Lancaster
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:d3563398
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-14 21:11 UTC by Marcel
Modified: 2010-09-15 05:51 UTC (History)
4 users (show)

Fixed In Version: Miro-3.0.3-1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-14 05:03:35 UTC


Attachments (Terms of Use)
File: backtrace (1.40 KB, text/plain)
2010-01-14 21:11 UTC, Marcel
no flags Details

Description Marcel 2010-01-14 21:11:30 UTC
abrt 1.0.3 detected a crash.

backtrace
-----
Summary: TBd3563398 __init__.py:820:_open:IOError: [Errno 13] Permission non accordée: '/home/bouchindhommeh/.miro/miro-log'

Traceback (most recent call last):
  File "/usr/bin/miro.real", line 268, in <module>
    startapp()
  File "/usr/bin/miro.real", line 225, in startapp
    startup(props_to_set)
  File "/usr/bin/miro.real", line 147, in startup
    startup.initialize(parsed_options.theme)
  File "/usr/lib64/python2.6/site-packages/miro/startup.py", line 148, in initialize
    setup_logging()
  File "/usr/lib64/python2.6/site-packages/miro/plat/utils.py", line 118, in setup_logging
    rotater = logging.handlers.RotatingFileHandler(config.get(prefs.LOG_PATHNAME), mode="w", maxBytes=100000, backupCount=5)
  File "/usr/lib64/python2.6/logging/handlers.py", line 107, in __init__
    BaseRotatingHandler.__init__(self, filename, mode, encoding, delay)
  File "/usr/lib64/python2.6/logging/handlers.py", line 59, in __init__
    logging.FileHandler.__init__(self, filename, mode, encoding, delay)
  File "/usr/lib64/python2.6/logging/__init__.py", line 801, in __init__
    StreamHandler.__init__(self, self._open())
  File "/usr/lib64/python2.6/logging/__init__.py", line 820, in _open
    stream = open(self.baseFilename, self.mode)
IOError: [Errno 13] Permission non accordée: '/home/bouchindhommeh/.miro/miro-log'

Local variables in innermost frame:
self: <logging.handlers.RotatingFileHandler instance at 0x1d54f80>

cmdline: /usr/bin/python /usr/bin/miro.real
component: Miro
executable: /usr/bin/miro.real
kernel: 2.6.31.9-174.fc12.x86_64
package: Miro-2.5.4-1.fc12
uuid: d3563398

Comment 1 Marcel 2010-01-14 21:11:33 UTC
Created attachment 384452 [details]
File: backtrace

Comment 2 Alex Lancaster 2010-01-15 00:45:57 UTC
Can you describe the exact conditions to reproduce this crash?  Without that, it's very difficult to fix the bug.

Comment 3 Alex Lancaster 2010-07-18 08:48:39 UTC
Reporter: can you still reproduce this in the current version of Miro: 3.0.2?  If not, or if I don't hear a response within 1 week, I'll close this bug.  If you can reproduce you're always free to re-open it.

Comment 4 Fedora Update System 2010-08-29 17:18:56 UTC
Miro-3.0.3-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/Miro-3.0.3-1.fc14

Comment 5 Fedora Update System 2010-08-29 17:26:02 UTC
Miro-3.0.3-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/Miro-3.0.3-1.fc13

Comment 6 Fedora Update System 2010-08-29 17:30:08 UTC
Miro-3.0.3-1.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/Miro-3.0.3-1.fc12

Comment 7 Fedora Update System 2010-08-30 19:40:40 UTC
Miro-3.0.3-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update Miro'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/Miro-3.0.3-1.fc14

Comment 8 will kahn-greene 2010-08-30 21:22:22 UTC
Looks like the user doesn't have permission to write to that file/directory.  Hard to say why, but that sounds like a file permissions problem.

Comment 9 Fedora Update System 2010-09-14 05:01:32 UTC
Miro-3.0.3-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2010-09-15 05:33:30 UTC
Miro-3.0.3-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2010-09-15 05:48:38 UTC
Miro-3.0.3-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.