Bug 55562 - 2.4.9-7 kernel breaks ide-tape.
2.4.9-7 kernel breaks ide-tape.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-01 18:30 EST by Ian Mortimer
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-02 21:48:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Mortimer 2001-11-01 18:30:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-10 i686)

Description of problem:
I have an Onstream ide tape drive which worked fine
under RH 7.1 with the RH kernels and also with standard
Linux kernels 2.4.8, 2.4.9 and 2.4.10.  After an upgrade
to RH kernel 2.4.9-7 it stops working.

Version-Release number of selected component (if applicable):
2.4.9-7


How reproducible:
Always

Steps to Reproduce:
1.Upgrade to 2.4.9-7 kernel
2.modprobe ide-tape
3.Try any tape access command. e.g.: 
   mt -f /dev/ht0 status
	

Actual Results:  The command returns no such device.  lsmod
shows the ide-tape module loaded but this error appears
in /var/log/messages:

 modprobe: Can't locate module char-major-97


and appears to be related.

Expected Results:  The mt command should execute: reporting the drive
status or rewinding the tape or whatever.

Additional info:

This tape drive worked fine with a standard linux
2.4.9 kernel previously under RH 7.1 which indicates
the failure is due to RH's kernel modifications
and not a flaw in the 2.4.9 kernel itself.

It works fine with kernel 2.4.7-10 shipped with RH 7.2.
Comment 1 Pete Zaitcev 2001-11-02 21:48:04 EST
Requestor, please do the following. Sorry for the fuzzy
instructions... Find what "hard disk" would correspond
to the tape if it was on the same "address", and identify
its directory in /proc/ide/ide?/hd?

Suppose, that it is /proc/ide/ide0/hdb. Do this:
"grep debug_level /proc/ide/ide0/hdb", it should find
something if this is a tape, nothing for hard disks.

Then, do:

# echo debug_level:6 > /proc/ide/ide0/hdb/settings
# mt -f /dev/ht0 status
<error messages>
# echo debug_level:0 > /proc/ide/ide0/hdb/settings
# dmesg > /tmp/dmesg.out

In the end, attach the resulting dmesg.out to the bug.
Please, do not drop dmesg contents into the comments box.
Comment 2 Ian Mortimer 2001-11-07 18:35:41 EST
I didn't get a chance to try your suggestion before today since I needed the
tape drive for backups.  This morning I upgraded to kernel 2.4.9-13 amd the
problem has disappeared.

BTW the message: `modprobe: Can't locate module char-major-97' seems to be 
unrelated to this problem.  It appears to be connected with ide-scsi (I've got
a CD burner in the same box).

Note You need to log in before you can comment on or make changes to this bug.