Bug 555624 - build python3 version of python-deltarpm
build python3 version of python-deltarpm
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: deltarpm (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jonathan Dieter
Fedora Extras Quality Assurance
:
Depends On: 564527
Blocks: Python3F13
  Show dependency treegraph
 
Reported: 2010-01-14 20:37 EST by Thomas Spura
Modified: 2010-02-15 12:09 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-15 11:56:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch for building python3 subpackage (2.22 KB, patch)
2010-01-14 20:37 EST, Thomas Spura
no flags Details | Diff
patch for building python3 subpackage (2.22 KB, patch)
2010-02-10 06:44 EST, Thomas Spura
no flags Details | Diff

  None (edit)
Description Thomas Spura 2010-01-14 20:37:50 EST
Created attachment 384498 [details]
patch for building python3 subpackage

python3 is now in rawhide, see
http://lists.fedoraproject.org/pipermail/devel/2010-January/129185.html

Attached is a patch against current CVS checkout, which builds the python3
subpackage on every distribution with %{?fedora} > 12, where currently the
python3 package is build.


Koji builds:
F-12: http://koji.fedoraproject.org/koji/taskinfo?taskID=1922741
F-13: http://koji.fedoraproject.org/koji/taskinfo?taskID=1922738


(The patch also changes %define -> %global in the first line)
Comment 1 Thomas Spura 2010-02-10 06:44:28 EST
Created attachment 389973 [details]
patch for building python3 subpackage

Jonathan, this patch is mostly up to date. Could you please have a look at this?


Or may I check in?
Comment 2 Jonathan Dieter 2010-02-10 08:05:25 EST
Ok, I've just applied the patch and built it, but I'm getting this failure:
http://koji.fedoraproject.org/koji/getfile?taskID=1973985&name=build.log
http://koji.fedoraproject.org/koji/getfile?taskID=1973986&name=build.log

I have no idea what the problem is, though my guess would be that it's a BuildRequires problem.

If you don't mind looking into it, that would be great (and feel free to check in the fix once you've verified that it does build).
Comment 3 Dave Malcolm 2010-02-10 08:51:25 EST
(In reply to comment #2)
> Ok, I've just applied the patch and built it, but I'm getting this failure:
> http://koji.fedoraproject.org/koji/getfile?taskID=1973985&name=build.log
> http://koji.fedoraproject.org/koji/getfile?taskID=1973986&name=build.log
> 
> I have no idea what the problem is, though my guess would be that it's a
> BuildRequires problem.
Looks like that might be an issue with the python3 package itself: looking at 
http://koji.fedoraproject.org/koji/getfile?taskID=1973985&name=root.log
I see that it install python3-devel, which brings in python3, but has not brought in python3-libs.

(installing python-devel brought in python _and_ python-libs).
Comment 4 Jonathan Dieter 2010-02-10 08:56:41 EST
Ok, so wait a couple of days for this to get fixed and rebuild again?
Comment 5 Dave Malcolm 2010-02-12 09:35:42 EST
Sorry, I got bogged down in another issue; I hope to have a proper look at this today.
Comment 6 Dave Malcolm 2010-02-12 20:07:53 EST
I've written up the python3 dependency issue as bug 564527 but haven't actually fixed it yet.  Sorry about this.
Comment 7 Thomas Spura 2010-02-13 05:10:57 EST
I added the BR on the libs package manually with a FIXME to remember, that this can be deleted again, when bug 564527 is gone again.

I did this, to get this build before Alpha Freeze, so this is build, when No Frozen Rawhide is coming.

http://fedoraproject.org/wiki/No_Frozen_Rawhide_Implementation

koji build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1981759

(leaving open, till BR FIXME is gone)
Comment 8 Jonathan Dieter 2010-02-13 05:17:30 EST
Ok, thanks.
Comment 9 Thomas Spura 2010-02-15 11:56:41 EST
python3 bug is gone.

Scratch build is ok:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1988536


Because this didn't change the requires or something else, I decided, to not rebuild this and just made the changes in CVS. Feel free to do a rebuild yourself.


Closing.
Comment 10 Jonathan Dieter 2010-02-15 12:09:39 EST
Thanks for your work on this.  I'll go ahead and wait until we make a change before rebuilding.

Note You need to log in before you can comment on or make changes to this bug.