This service will be undergoing maintenance at 03:30 UTC, 2016-05-27. It is expected to last about 2 hours
Bug 555628 - build python3 version of b43-tools
build python3 version of b43-tools
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: b43-tools (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: Python3F13 PYTHON3-UPSTREAM
  Show dependency treegraph
 
Reported: 2010-01-14 21:07 EST by Thomas Spura
Modified: 2016-05-10 16:21 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-07 05:20:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch for building for python3 only (2.79 KB, patch)
2010-01-14 21:07 EST, Thomas Spura
no flags Details | Diff

  None (edit)
Description Thomas Spura 2010-01-14 21:07:18 EST
Created attachment 384503 [details]
patch for building for python3 only

python3 is now in rawhide, see
http://lists.fedoraproject.org/pipermail/devel/2010-January/129185.html

Attached is a patch against current CVS checkout, which builds for python3 *ONLY* on every distribution with %{?fedora} > 12, where currently the
python3 package is build.

I decided to *NOT* include a python3 subpackage, because nothing requires this directly any I doubt this is used with python2 very much.

It's not a problem to ship it in a subpackage, but I just wouldn't to that.

What's your opinion towards this?
(This will then be the first package, that is build for python3 only :-) *yay* )


Koji builds:
F-12: http://koji.fedoraproject.org/koji/taskinfo?taskID=1922772
F-13: http://koji.fedoraproject.org/koji/taskinfo?taskID=1922762


(The patch also changes %define -> %global in the first line)
Comment 1 Bug Zapper 2010-03-15 10:00:27 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Thomas Spura 2010-08-19 17:11:22 EDT
Ping.
Comment 3 Tomas Orsava 2016-03-01 09:53:20 EST
Upstream, this software supports Python 3. Please provide a Python 3
package for Fedora.


According to the Python packaging guidelines [0], software must be
packaged for Python 3 if upstream supports it.
The guidelines give detailed information on how to do this, and even
provide an example spec file [1].

The current best practice is to provide subpackages for the two Python
versions (called "Common SRPM" in the guidelines). Alternatively, if
nothing depends on your Python2 package, you can just switch to Python 3
entirely.

It's ok to do this in Rawhide only, however, it would be greatly
appreciated if you could push it to Fedora 24 as well.


If anything is unclear, or if you need any kind of assistance with the
porting, you can ask on IRC (#fedora-python on Freenode), or reply here.
We'll be happy to help!


[0] https://fedoraproject.org/wiki/Packaging:Python
[1] https://fedoraproject.org/wiki/Packaging:Python#Example_common_spec_file
Comment 4 Dominika Krejčí 2016-05-06 10:51:33 EDT
Hello Peter,

Do you need any help adding Python 3 support to the RPM?

If you need more instructions, a [guide] for porting Python-based RPMs is available.

[guide] http://python-rpm-porting.readthedocs.org/en/latest/index.html
Comment 5 Peter Lemenkov 2016-05-07 05:20:47 EDT
(In reply to Dominika Krejčí from comment #4)
> Hello Peter,
> 
> Do you need any help adding Python 3 support to the RPM?
> 
> If you need more instructions, a [guide] for porting Python-based RPMs is
> available.
> 
> [guide] http://python-rpm-porting.readthedocs.org/en/latest/index.html

Hello Dominika!
Unfortunately I'm not interested in this. I see this not as a bug but rather as a feature request. This should be done upstream first.

So please go to upstream, propose changes required for adding thisPython3 support, and then (and only then) I'd happy to apply it for Fedora package.

So far I'm going to close this as a NOTABUG (since it's not a bug).
Comment 6 Tomas Orsava 2016-05-09 06:56:59 EDT
(In reply to Peter Lemenkov from comment #5)
> (In reply to Dominika Krejčí from comment #4)
> > Hello Peter,
> > 
> > Do you need any help adding Python 3 support to the RPM?
> > 
> > If you need more instructions, a [guide] for porting Python-based RPMs is
> > available.
> > 
> > [guide] http://python-rpm-porting.readthedocs.org/en/latest/index.html
> 
> Hello Dominika!
> Unfortunately I'm not interested in this. I see this not as a bug but rather
> as a feature request. This should be done upstream first.
> 
> So please go to upstream, propose changes required for adding thisPython3
> support, and then (and only then) I'd happy to apply it for Fedora package.
> 
> So far I'm going to close this as a NOTABUG (since it's not a bug).

Hi Peter,
thank you for responding!

I'd like to ask for clarification: Is this package not Python 3 compatible upstream? Because if the patch by Thomas Spura worked, then upstream must be Python 3 compatible. Or am I missing something?

Thank you for your time!
Comment 7 Peter Lemenkov 2016-05-09 07:41:17 EDT
(In reply to Tomas Orsava from comment #6)
> 
> I'd like to ask for clarification: Is this package not Python 3 compatible
> upstream? Because if the patch by Thomas Spura worked, then upstream must be
> Python 3 compatible. Or am I missing something?

I really don't know if it's compatible or not.
Comment 8 Tomas Orsava 2016-05-09 10:13:08 EDT
(In reply to Peter Lemenkov from comment #7)
> (In reply to Tomas Orsava from comment #6)
> > 
> > I'd like to ask for clarification: Is this package not Python 3 compatible
> > upstream? Because if the patch by Thomas Spura worked, then upstream must be
> > Python 3 compatible. Or am I missing something?
> 
> I really don't know if it's compatible or not.

Well, given that there already is a Python 3 patch for the spec file, could you try it? It would be a great contribution towards the future of Python in Fedora!
Comment 9 Tomas Orsava 2016-05-10 10:02:45 EDT
One last time: Hi, Peter!

I want to apologize for the confusion, I finally got to investigating the provided patch more thoroughly and I found out that the project is indeed not Python 3 compatible, the patch was just pushing the code through the 2to3 utility.

Thank you for your time,
Tomas

Note You need to log in before you can comment on or make changes to this bug.