Bug 55563 - usb-storage and SCSI only systems
usb-storage and SCSI only systems
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.2
i386 Linux
low Severity low
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-01 20:09 EST by Ian Prowell
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-03 14:41:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Prowell 2001-11-01 20:09:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.5)
Gecko/20011011

Description of problem:
When installing RedHat 7.2 on a machine with only SCSI hard drives and a
usb-storage unit is plugged in the installer allocates sda to the
usb-storage unit.  The simple work around is to reinstall the OS without
the usb-storage unit plugged in.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.  Setup a SCSI only system with a usb-storage device
2.  Boot off a SCSI CD-ROM
3.  Step through the normal install procedure
4.  The hard drive that would normally be sda becomes sdb due to the
usb-storage device.
	

Actual Results:  The system would not boot because /etc/fstab had bad
values.  Also GRUB did not have the right configuration.

Expected Results:  sda should be consistant between the installer and the
actual boot.

Additional info:
Comment 1 Jeremy Katz 2001-11-02 16:05:57 EST
FYI, there is a boot disk which works around this problem at
http://people.redhat.com/~katzj/usbstoragedisk/.

This disk changes things so that we remove the usb-storage driver before loading
any other SCSI drivers and also adds a "nousbstorage" flag which can be passed
on the syslinux prompt to disable loading the usb-storage module altogether.
Comment 2 Brent Fox 2001-11-03 13:28:24 EST
Does the updates disk fix the problem?
Comment 3 Ian Prowell 2001-11-03 14:41:09 EST
I already finished installing RedHat 7.2 on the only workstation I have that
only has SCSI.  I assume the provided boot disk solves the problem.  Just wanted
to make sure that this got into the install documentation or was solved by an
update.
Comment 4 Brent Fox 2001-11-06 16:38:58 EST
Ok.  This problem should not appear in future releases.  Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.