Bug 55578 - xemacs open file box misunderstands national characters (iso8859-1)
xemacs open file box misunderstands national characters (iso8859-1)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: xemacs (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-02 06:30 EST by Stelian Pop
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-06 14:38:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stelian Pop 2001-11-02 06:30:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-7 i686; Nav)

Description of problem:
I have files and directories containing non ASCII-127 characters (French
characters with i, `, g etc).

When trying to open those files (or enter the directories) using the open
file box in XEmacs a wrong name is picked (^A inserted) so I can't open the
file. Note that C-x C-f works correctly.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. touch iii
2. xemacs &
3. in xemacs window, click open, and see the file name ^Ai^Ai^Ai
4. try to middle click on the file name

Additional info:
Comment 1 Stelian Pop 2001-11-02 06:32:36 EST
As an additionnal info, I first saw this with RH 7.1 (or was it RH 7.0),
probably when MULE support was added in.

No version of xemacs ever corrected this since then (I am running the latest
errata xemacs:  xemacs-21.1.14-23.7.2).

Stelian.
Comment 2 Trond Eivind Glomsrxd 2001-11-06 14:38:45 EST
Reproduced
Comment 3 Trond Eivind Glomsrxd 2001-11-07 11:44:34 EST
It's a problem in xemacs 21.1 regardless of widget set used - upgrading to their
gamma releases, 21.4.x, solves the problem. 21.4.5 is now built.

Note You need to log in before you can comment on or make changes to this bug.