Bug 55587 - Neomagic problems causing by configuration
Neomagic problems causing by configuration
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-02 10:30 EST by Alan Cox
Modified: 2007-04-18 12:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-24 11:44:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2001-11-02 10:30:16 EST
One some laptops XFree86 4.x hangs erratically (often  every two or 
three days) on some neomagic chips. 

The documentation says
       On  some laptops using the 2160 chipset (MagicGraph 128XD)
       the following options are needed to avoid a lock-up of the
       graphic engine:
           Option "XaaNoScanlineImageWriteRect"
           Option "XaaNoScanlineCPUToScreenColorExpandFill"

These options cause nothing more than a tiny slowdown on other 2160 using
hosts so I feel Xconfigurator should write those lines in for the affected
chipset regardless. End users are not going to be able to follow man
neomagic and what is needed.

3.3.x also breaks with the Xconfigurator complaining that XF86_None is not
installed when you use --preferxf3

This shows up on Telsa's laptop so fixing it might make my life a lot easier 8)
Comment 1 Bill Nottingham 2001-11-02 11:06:35 EST
Does this hang require a complete poweroff to properly reset the card?
(i.e., does starting the X server again without a cold boot also hang?)

Just trying to correlate this with hangs on other neomagic chipsets.
Comment 2 Alan Cox 2001-11-02 11:25:22 EST
Restarting an Xserver until a cold power off also hangs yes
Comment 3 Telsa Gwynne 2001-11-02 11:32:37 EST
"Mid-air collision detected!" Alan beat me to it. On *my* bug. 

Yes. It does. I have to switch off completely before I reboot.

I have added the two magic lines now. Btw, it's much more variable
than "every two or three days". Sometimes it's within half an hour
of the last one.Sometimes it stays up for nearly a week.
Comment 4 Bill Nottingham 2001-11-02 12:43:31 EST
OK, so this appears to apply to other Neomagic chipsets, such as:

01:00.0 VGA compatible controller: Neomagic Corporation NM2360 [MagicMedia 256ZX]
Comment 5 Sunny Chan 2001-12-21 09:38:02 EST
I have a similar problem with my laptop - It is a IBM Thinkpad 600X, using Neomagic
2360 chipset. The screen is corrupted when I use X under 1024x768x24/32bit - the
windows and characters will disintegrate. However with the above two lines it
seems to fix the problem.
Comment 6 Mike A. Harris 2002-03-11 02:14:30 EST
These options are now the default for all neomagic variants.
Comment 7 Mike A. Harris 2002-11-23 21:18:57 EST
I am removing these options from the hardware database for 2 purposes:

1) To test and see if the bugs are fixed
2) To implement an alternate more robust solution if it is not fixed yet,
   by either fixing it, getting someone to fix it, or disabling the code
   directly in the driver source.  This way nobody can enable the broken
   code, and upgrades also work from distro to distro without relying on
   whatever a user has in their config file before upgrade.

Please test the current CVS XFree86 4.2.99.2 driver if at all possible,
and remove or comment out all swcursor options, and "XaaNoxxxxxx" options
as well as noaccel et al.
If a problem occurs, please open a new bug report against rawhide, and
perhaps point out this bug as reference also.

Just attempting to clean up some of the prior dirty bandaids with cleaner
bandaids.

Thanks

Comment 8 Alan Cox 2002-11-24 17:46:14 EST
The XFree86 documentation still explicitly states that this is neccessary in
4.2.99 from 8.0.90
Comment 9 Alan Cox 2002-11-24 17:46:45 EST
Reopened since either the bug or the docs need fixing. Still needs testing to
see which
Comment 10 Mike A. Harris 2002-11-25 07:31:07 EST
I think you misunderstood me a bit...   The prior solution was a rather
poor bandaid, which has ended up causing some other unexpected problems
when people upgrade from older releases to 8.0.  What I want to do is
remove the bandaid, and replace it with either a real fix, or a better
bandaid directly in the driver itself.

Basically, if the cursor can't be fixed, I want to disable the section
of code for hwcursor in the driver, then we can flush out the various
adhoc Cards database hacks.

The problem is when someone was using an older driver and not experiencing
the problem, then upgrades to 8.0, their config file is not changed, and
bang - incoming bug reports.  This is a regression for them, and so I'd
like to fix the broken code, or if not, disable it, so that users don't
have to twiddle config options, or get hurt on upgrades.

Sorry for confusion.  ;o)  Now I know i've got a beta tester though.  ;o)

<evil grin>
Comment 11 Alan Cox 2002-11-25 09:09:41 EST
Its nothing to do with the cursor, its a hardware bug. Ask Bill for the
documentation for the neomagic and the errata docs
Comment 12 Mike A. Harris 2002-11-25 09:47:59 EST
The docs Bill has are under NDA, and he has not gotten clearance from
neomagic to do anything useful with them.  I don't want docs under NDA
unless I can do something with them personally for open source.

So unless they open up the docs, or they fall off the back of a truck,
I don't want Bill's copies as they are accounted for.

I will go inside the driver guts and disable these two options on
the 2160.  I'll put that into CVS, and make a patch for 4.2.1 erratum
also.
Comment 13 Mike A. Harris 2002-11-25 09:54:14 EST
Also...  Did any previous version of XFree86 4.x work on this chip
without disabling acceleration components?  If so, I can try to find
the breakage with rdiff
Comment 14 Mike A. Harris 2002-11-25 10:25:08 EST
sunnychan@uk.ibm.com) What version of XFree86 are the above
options needed for your particular chip?

I just found a small bug in the neomagic driver source, which might
explain this for the 2160, but not for the 2360.
Comment 15 Mike A. Harris 2002-11-25 10:33:12 EST
Right now, I'm working on the CVS X driver, but if it is impossible for
one of you to test XFree86 CVS X for me, let me know and I will hack
on earlier X code also, and provide test driver for 7.[123] and 8.0
stock XFree86 if needed.
Comment 16 Mike A. Harris 2003-01-24 11:44:36 EST
Neomagic configuration defaults, etc. are much different now than in the
past.  I also fixed a few driver bugs found while driver code surfing
with lots of coffee.  Been in rawhide for quite a while.

If any new neomagic problems come up, please file new reports, and we should
be able to find/fix them rather quickly.

Note You need to log in before you can comment on or make changes to this bug.