Bug 55588 - (SCSI AIC7XXX)Installer hangs when loading aic7xxx module on Supermicro P3TDE6 motherboard
(SCSI AIC7XXX)Installer hangs when loading aic7xxx module on Supermicro P3TDE...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-02 10:32 EST by Ray Muno
Modified: 2008-08-01 12:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ray Muno 2001-11-02 10:32:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-SGI_XFS_1.0.1smp i686)

Description of problem:
When trying to install Redhat 7.1 on a new Supermicro P3TDE6 motherboard
(dual tualatin 1.26 GHz PIII), the installer randomly hangs when loading
the aic7xxx module.

The motherboard has an integrated dual channel Adaptec 7899 comtroller and
is based
on the Serverworks HE-SL chipset..

The install does not always hang at that point. Sometimes it will start
installing and get
partway through and hang. At other times, it has actually succeeded.  If it
does succeed, the machine does not boot reliably.

I have over 50 of the 370DE6 version of this motherboard. The P3TDE6 is the
tualatin 
respin. 

Supermicro posted a workaround and it seems to allude to problems with the
3.10S
version of the SCSI BIOS.

http://www.supermicro.com/TECHSUPPORT/FAQs/SCSI_FAQ.htm

After working with Supermicro, they provided me with the BIOS image
equivalent to me 370DE6 boards with version 2.572 of the SCSI BIOS.  The
problem does not go away.

The workaround is to install with "expert noprobe" and install the "New
experimental
AIC7xxx module".  I do this and it works, it loads aic7xxx_mod instead of
aic7xxx.

Can the aic7xxx_mod module be forced to load at boot? I want to install
these machines with kickstart, not do every one of them by hand.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.boot Redhat 7.1 CD
2.machine most always hangs at "loading AIC7xxx" point
3.
	

Actual Results:  machine most always hangs at "loading AIC7xxx" point.  If
it loads the driver, it
may hang when writing to the disk.  When it does, the disk light just stays
on.

Additional info:

The problem seems to exist in Redhat 7.2 as well.
Comment 1 Brent Fox 2001-11-03 10:30:22 EST
Changing component to the kernel.
Comment 2 Arjan van de Ven 2001-11-03 10:36:14 EST
Can you try the 7.2 distro and type "linux apic" on the VERY first (syslinux)
screen ?
Comment 3 Ray Muno 2001-11-05 14:12:02 EST
I tried the 7.2 distro with "linux apic" and it hung at the "Loadin aic7xxx
driver" screen as 
before.

Did you mean to try linux noapic?
Comment 4 Andy Mueller 2002-01-04 23:49:53 EST
Hi,
I too have had problems with a new P4 Supermicro board.  My results were the
same & I had to resort to using the workaround provided at
http://www.supermicro.com/TECHSUPPORT/FAQs/SCSI_FAQ.htm
Of course, that kinda sucks.

I was able to get this working for my kickstart as well however.  I kickstart
from floppy.  Here is what I did (note: I don't have the exact syntax below but
you should get the idea):

- Modifdied ks floppy syslinux.cfg to add "expert noprobe"
- Modifed ks.cfg to specify devices manually (I also have a qlogic fc card):
  device scsi aic7xxx_mod
  device scsi qla2x00

- Modified ks.cfg postinstall to:
  remove duplicate scsi SCS_hostadapter lines in modules.conf & then
  cd /boot
  /sbin/mkinitrd -f initrd-2.4.2-2.img 2.4.2-2
 
After all that and a lot of headaches, it worked.
Let me know if you figured out something better....
Thanks,
Andy
Comment 5 michael 2002-01-10 14:59:02 EST
When trying to install Redhat 7.2 on a new Supermicro P4DC6+ motherboard
(Dual Xeon 2.0GHz), the installer hangs every time when loading the aic7xxx module.

You have to update your Mainboard bios to R1.1A or higher.

You must download the seeprom.zip and follow the instructions:

Steps to reload SCSI EEPROM to default if using older SCSI bios and upgrade to
SCSI BIOS 3.10S2
\
a. Copy SEEPROM.EXE and DOS4GW into a bootable Floppy disk.
b. Boot up the system from this bootable diskette.
c. At the prompt, 
d. Erase the SEEPROM by A:\seeprom -e
e. Reboot the system
f. Hit Ctrl + A to go into the system SCSI BIOS
g. Go to each channel and choose "Configure/View SCSI Controller Settings"
h. Hit F6 to load default setting.  This will allow system to load new values
from 3.10S2


You must update the BOTH. Then you should be able to install Red Hat 7.2


Mainboard bios download:
http://www.supermicro.com/TECHSUPPORT/BIOS/bios.htm

Seeprom download:
http://www.supermicro.com/TECHSUPPORT/drivers/seeprom.zip
Comment 6 Need Real Name 2002-01-26 20:19:43 EST
I get the Installer hang on my box. 
      - Adaptec 29160
      - Tyan Tiger S1384 (Dual P-3)
and the installer hangs on the install (RH 7.1)

i tried the boot disk... any other ideas?
Comment 7 Need Real Name 2002-12-05 21:58:53 EST
I tried following version of redhat on my ( pIII 866*2 with SCSI aha-2940):
6.2  hang up at disk druid
7.1  hang up at probing mouse
7.2  hang up at disk druid
7.3  hang up at disk druid 
8.0  hang up at loading aic7xxx driver(some time can pass through)
Comment 8 Bugzilla owner 2004-09-30 11:39:14 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.