Bug 55589 - Poweroff does not work with 2.4.7 even in realmode.
Poweroff does not work with 2.4.7 even in realmode.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
athlon Linux
medium Severity low
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-02 10:53 EST by Hans Deragon
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-02 02:22:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans Deragon 2001-11-02 10:53:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2)
Gecko/20010726 Netscape6/6.1

Description of problem:
Since I upgrade to RH 7.2 kernel 2.4.7, I cannot poweroff my computer
anymore. Under RH 7.1 kernel 2.4.2, powering off worked fine.

I tried the following:

 1)  .config of kernel:  CONFIG_APM_REAL_MODE_POWER_OFF=y
     /etc/grub.conf:     kernel /boot/vmlinuz-2.4.7-10world ro
root=/dev/hda1 hdb=ide-scsi apm=realmode

 2)  .config of kernel:  CONFIG_APM_REAL_MODE_POWER_OFF=y
     /etc/grub.conf:     kernel /boot/vmlinuz-2.4.7-10world ro
root=/dev/hda1 hdb=ide-scsi

 3)  .config of kernel:  # CONFIG_APM_REAL_MODE_POWER_OFF is not set
     /etc/grub.conf:     kernel /boot/vmlinuz-2.4.7-10world ro
root=/dev/hda1 hdb=ide-scsi apm=realmode

 4)  .config of kernel:  # CONFIG_APM_REAL_MODE_POWER_OFF is not set
     /etc/grub.conf:     kernel /boot/vmlinuz-2.4.7-10world ro
root=/dev/hda1 hdb=ide-scsi

In all circumstances, I get the famous "Power down." message
asking me to shutdown manually my computer.

I search Usenet and found this:

  http://groups.google.com/groups?q=apm+poweroff.under.linux.2.4.7+alan&hl=fr

It might provide some clue.  I have not tried taking the
2.4.2 apm.c file and plug it into 2.4.7.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Type "poweroff" at shell or select "shutdown" in gnome logout applet.
	

Actual Results:  Computer freezes after showing up on screen "Power down.".
CTRL-ALT-DEL does not respond.

Expected Results:  Computer should poweroff.

Additional info:

I have decided to be nice and give this problem a low priority,
since its possible to shutdown the computer manually.  But its
annoying and my home server is expected to shutdown after 22h00
and restart the next day at 5h55.  I liked it when all this
was automatic.
Comment 1 josip 2001-11-04 21:01:16 EST
I see the same problem (including kernel 2.4.9-13) but this is a normal or even
high priority item for us because we operate a sizable cluster which we need to
power off automatically if overheating is detected.  The cluster dissipates more
than 7.5KW in normal operation, so unless it is actually powered off when the
A/C fails, the temperature in the room can rise rapidly to equipment damaging
levels.  It is unreasonable to expect that someone can be summoned within 15-20
minutes at odd hours of the night simply to push almost a hundred power
switches.  I'd like to see poweroff working the way it used to.
Comment 2 Arjan van de Ven 2001-11-05 03:59:36 EST
Can you try passing "apm=realmode_power_off" to the kernel commandline (for
grub, edit /boot/grub/grub.conf and add it to the line which also has "vmlinuz"
on it)?
Comment 3 Hans Deragon 2001-11-05 11:16:27 EST
Tried this in /etc/grub.conf:

title Red Hat Linux-up (2.4.9-13 for World)
  root (hd0,0)
  kernel /boot/vmlinuz-2.4.9-13world ro root=/dev/hda1 hdb=ide-scsi
apm=realmode_power_off

...and it failed.  However, contrary to the 2.4.7-10 kernel, when the "Power
down." message
appear, CTRL-ALT-DEL does work to reset the machine.  In this test, the APM was
built as
a module and no, I have not forgotten to load it before performing the poweroff.

Where are all the apm options documented?  I would like to know why you believed
that
realmode_power_off is a valid token.

Finally, on a different topic:  Are you guys aware that the Mozilla version you
ship with RH 7.2
(Mozilla 0.9.2) cannot show up the https://bugzilla.redhat.com/bugzilla
website?  Pass the
comment through your organization; I believe that an updated Mozilla should be
made available
on your ftp site.
Comment 4 Hans Deragon 2001-11-12 21:15:47 EST
I replace the 2.4.9 apm.c file with the version provided by 2.4.2, as I read in
a thread with Alan Cox on the web, but it did not work.  BTW, I checked the
source code and found out how you came out with the apm=realmode_power_off.
Comment 5 Hans Deragon 2003-06-01 18:42:04 EDT
Since RH 8.0, poweroff worked again.  I guess that it was a fluke with the RH
7.2 kernel...  You may close this bug report if nobody else is interested.  I am
not anymore.

Note You need to log in before you can comment on or make changes to this bug.