Bug 55591 - Shell PATH being written oddly
Summary: Shell PATH being written oddly
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rootfiles (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-02 16:09 UTC by Phil Copeland
Modified: 2014-03-17 02:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-02 16:09:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Phil Copeland 2001-11-02 16:09:35 UTC
Parcelfarce is a 7.1 box upgraded to 7.2
I've also verified the SAME on a fresh 7.2 box

[root@parcelfarce /root]# rpm -qf /root/.bash_profile
rootfiles-7.0-4
[root@parcelfarce /root]# cat /root/.bash_profile
...
PATH=/usr/local/sbin:/usr/sbin:/sbin:$PATH:$HOME/bin
...

HUMMM

[root@parcelfarce /root]# rpm -qf /root/.cshrc 
rootfiles-7.0-4
[root@parcelfarce /root]# cat /root/.cshrc 
setenv PATH "/usr/local/sbin:/usr/sbin:/sbin:${PATH}:${HOME}/bin"

Erm ,well whats in there by default?

[root@parcelfarce /root]# ls /usr/local/sbin
[root@parcelfarce /root]#

Answer nothing. So why is it being added at the FRONT of the the path
statement? In fact, why is it being added at all?

Comment 1 Bill Nottingham 2002-01-25 05:30:05 UTC
Since /usr/local/bin is added for normal users, /usr/local/sbin is added for
consistency for root users.


Note You need to log in before you can comment on or make changes to this bug.