Bug 55592 - Installation Image will not load to HD
Installation Image will not load to HD
Status: CLOSED DUPLICATE of bug 37280
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-11-02 11:49 EST by Kevin Thomas
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-01-18 16:02:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Kevin Thomas 2001-11-02 11:49:41 EST
Description of Problem:

1. I have reported this to technical support and they are aware of it. My 
RedHat account name is klthoms.
2. With the assistance of tech support, I've tried to install Red Hat 7.1 
Deluxe onto my computer system. I chose the server installation. I get 
though to the end of the set up and the program formats the filesystem. 
Then the program tries to transer to the install image to the hard drive. 
At this point, it stops, saying it a encountered an error and says that 
I'm out of disk space. 
3. The technical support analyst is investigating and indicated that I 
submit this bug report.

Version-Release number of selected component (if applicable):

I'm purcahsed Red Hat 7.1 Deluxe Workstation.

How Reproducible:

I followed the standard installation procedures as outlined in the 
manuals. The support tech walked me through them again and produced the 
same result.

Steps to Reproduce:
1. Follow the standard installation procedures.

Actual Results:

Errors out and with no OS installed on system.

Expected Results:

Functiong Linux Server.

Additional Information:
The computer system I'm installing this on is a Compaq Deskpro 2000. 
233MMX/Mhz, 8GB Seagate Drive, 288MG of RAM, Sony 16x CDROM drive. The 
video card is Trio64V2/GH (S3/VirageGX), audio is ESS Audio, NIC card is a 
Netelligent 10T PCI card, Modem is a Netelligent 56K ISA Fax Modem. The 
monitor that I'm using is Samsung SyncMaster 570V TFT, which the install 
program did not recognize, nor was there a generic flat screen option in 
the setup.
Comment 1 Brent Fox 2001-11-03 10:29:38 EST
What partitions did you make and how big were they?

The flatpanel probably isn't detected because some flatpanels don't provide
information about themselves the way most CRT's do.  Some of the newer
flatpanels are starting to provide more detection capability, though.  We can
investigate this further once we get your system installed.  

In the monitor screen in the installer, there's an entry for "Samsung."  There
should be an entry for "Samsung SyncMaster 570B TFT/580B TFT".  This should be
the correct monitor for you.
Comment 2 Kevin Thomas 2001-11-04 14:50:15 EST
With respect to paritions, when I tried the first time, I created partition 
sizes based on what was in the Installation Manual, page 21. When did the same 
steps with the technical support person, we used automatic partitions and let 
the installer determine the size.

Roughly I used, 256MB for swap, 512MB for /user, 512MB for /home, 256MB 
for /var, 32MB for /boot and the rest of the 8GB drive as /(root). I did try 
adjusting the swap size down to 128 because there was a reference in the manual 
that the max should be no more that 128. I even tried the swap size 2XRAM which 
was 576 and that didn't work.

As for the monitor, I did select the one you mentioned since it was the closet 
and felt it wouldn't be an issue.

Thanks for your help!

Comment 3 Brent Fox 2001-11-06 17:13:05 EST
Very strange.  It sounds like you are doing everything right.  Can you try
booting the install with 'linux noprobe' and see if that helps?  I think that
the kernel might be getting the geometry wrong on your hard drive and perhaps it
thinks the drive is smaller than it actually is.  Does that help at all?
Comment 4 Kevin Thomas 2001-11-06 18:58:26 EST

Per your suggestion, I started the installation as "linux noprobe" and 
unfortunately, the same error occured when trying to transfer the image. 

To be sure, I went back through the installation process and used fdisk with 
commands "O" and "W" to redo the disk allocation table. The tech support 
engineer had me do that orginally and I thought it a good idea. After that, I 
rebooted, and ran the installation as before. Same error message. *sigh*

Any thoughts or clues that I might be missing?

Thanks for your help!

Comment 5 Need Real Name 2001-11-07 17:17:48 EST
As a fellow Compaq Deskpro 2000 owner, I'm not sure if this is related but Be 
aware of bug 37280.   It effects our computers.
Comment 6 Brent Fox 2001-11-08 11:19:49 EST
kthomas6, when the install tells you that you are out of disk space, try
pressing <Ctrl><Alt><F4>.  Do you see any error messages that have anything to
do with the hard drives or cdrom?  Specifically, are there any messages that say
anything about "DMA"?
Comment 7 Kevin Thomas 2001-11-09 13:25:17 EST

First, I read through bug 37280. a) I have seen the error msg "Unknown EDD 
version 0x1600 supported" when I've had to reboot. b) I did not try the linux 
ide=nodma nousb as that did not appear to work for users. c) The Compaq I have 
has the VIA IDE Controllers. d) There appears to be some correlation between 
this bug and 37280. e) Somebody mentioned in the bug report 37280 about making 
the CDROM the slave drive off of the Primary IDE. I'm not sure how to do that, 
so I'll ask.

Second, check your forums because this bug is being reported there as well. 
I've provided the link below:


Additional clues maybe gleaned there.

Third, I ran the installation again per your instructions and did CTL-ALT-F4 
and here are the last couple of lines:

<4> hdc: command error: status = 0x51 { DriveReady SeekComplete Error }
<4> hdc: command error : error = 0x50 
<4> end_request: I/O error, dev 16:40 (hdc), sector 1109876

There was nothing about DMA. 

Fourth, in bug 37280 it's mentioned that Kernal versions 2.4.4 and 2.4.10 might 
resolve the VIA IDE controllers issue. Are those kernals present in RH 7.2? 
Have you tested 7.2 on these systems (Compaq Deskpro 2000's)? 


Kevin Thomas
Comment 8 Kevin Thomas 2001-11-16 18:09:49 EST
Dear Mr. Fox,

I contacted Tech Support yesterday to find out if there had been any resolution 
to this problem that I reported. For some reason, the person who originally 
told me to fill out the bug report did not open a "ticket" and I was 
subsequently lost in the system. 

Sandra, one of the techs opened a ticket, Number 848 and has it pending 
resolution through your organization. 

To that end, it's been almost a week since I posted my last update and I have 
not receieved any further comments or assistance with this problem.

Could you please contact me and provide me a status of this issue and what 
steps are being done to rectify the problem? I would greatly appreciate it.


Kevin Thomas
Comment 9 Brent Fox 2001-11-20 13:15:32 EST
Hi Kevin.  I apologize for the delay.  We don't have a Deskpro 2000 in house, so
I can't test 7.2 on it myself.  I have asked the kernel team and posted a
question on bug #37280 to see if anybody else has had any luck with this issue.  

One user says that 7.1 worked for him if he moves the cdrom drive to be the
Slave drive on the primary IDE controller.  Is it possible for you to try this?  

Here's how.  You system has two IDE controllers, a primary and a secondary.  The
ribbon cables allow for two drives to be connected to each controller.  However,
if you have more than one drive on one IDE controller, you must use the jumpers
on the drives themselves to determine which drive is Master and which drive is
Slave.  This allows the motherboard to give priority to one drive if both drives
try to transfer data at the same time.

Right now, the hard drive is the Master on the primary controller and your cdrom
drive is the Master drive on the secondary IDE controller.  Try removing the
ribbon cable from the cdrom drive and put it on the same ribbon cable that the
hard drive is on.  You will have to look on both the hard drive and the cdrom
drive for instructions on how to set the jumpers correctly.  You want the hard
drive to be Master and the cdrom drive to be slave.

Does that info help?
Comment 10 Kevin Thomas 2001-11-21 11:43:56 EST

Success! I made the CDROM a slave of the IDE controller, basically as you 
outlined above and it worked. I successfully installed both server, then wiped 
the drive and sucessfully installed workstation with no post-installation 

Further thoughts and next steps?

Comment 11 Brent Fox 2002-01-17 11:31:03 EST
Well, I'm not a kernel engineer, so I don't know exactly what the problem is. 
It seems that you have found a workaround, although it's not perfect.  Now that
you have the machine installed, I'm curious as to what would happen if you move
the cdrom back to being the master on the secondary IDE controller.  

The installer uses a "boot" kernel, which is a stripped down kernel with just
enough functionality to get the system installed.  Maybe the problem wouldn't
appear in the full kernel after installation.  Having said that, we haven't seen
this problem in house, so my guess is that there's something quirky about the
motherboard that the kernel doesn't quite like.

Since your system is working now, do you want to pursue this bug report further?
 It's up to you.
Comment 12 Kevin Thomas 2002-01-18 16:02:16 EST

I guess I could try to switch the CDROM back to the secondary controller at 
some point to test it out. But, I'm also of the mind "If it ain't broke, don't 
fix it" It installed fine and seems to be working.

I read somewhere that 7.2 had the same problems on a Deskpro 2000, so I still 
think there is a kernel issue that needs to be addressed by the engineers. 
Second, I think you could close the ticket associated with this bug, which is 

Beyond that, it appears to me that the kernel issue still needs to be addressed 
in later versions of Red Hat so they work with these older systems that people 
find or have. 

Comment 13 Brent Fox 2002-01-21 12:18:33 EST
I wish we had a Deskpro 2000 in house to test it on, but we don't.  I'm going to
dupe this bug against bug #37280 since that bug is already assigned to the
kernel team.  Thanks for your report.

*** This bug has been marked as a duplicate of 37280 ***

Note You need to log in before you can comment on or make changes to this bug.